Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS General Gear Talk Flash and Studio Lighting 
Thread started 20 Nov 2009 (Friday) 08:15
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

ST-E2 won't fire my 580EXII - Any ideas?

 
stevegreen
Member
121 posts
Joined Jan 2005
Location: Shropshire, UK
     
Nov 20, 2009 08:15 |  #1

As topic really. I have myt ST-E2 mounted on my 5D and although it is firing the red lamp on the front it's not firing the flash. I have lost my instructions for the 580EXII and am wondering if I have a custom function i need to change to get it to fire. The ST-E2 is on channel 1 and the ETTL light is lit.

Just the one flash............any ideas?


Pigs? .......... In there?
My Flickr  (external link)My Gear
My Website  (external link)My Blog (external link)

  
  LOG IN TO REPLY
TheFloridaShooter
Senior Member
713 posts
Gallery: 1 photo
Likes: 27
Joined Nov 2008
     
Nov 20, 2009 08:38 |  #2

Did you set the 580EX II as a SLAVE?


1Dx MKII | 1Dx | 5D MKIV | 5D MKIII | 5Ds r | 5Ds | 7D MKII | 7D | G16 | G3x | EOS M & M3 | 800 f5.6 | 600 f4 | 400 f2.8 | 300 f2.8 | 200-400 f4 | 100-400 f4.5 - 5.6 II x 2 | 70-200 f2.8 | 14 f2.8 II | 50 f1.2 | 50 1.4 | 85 f1.2 | 135 f2 | 24-70 f2.8 II | 11-24 f4 | 35 f1.4 II | Pentax 645Z | SMC Pentax-DA 645 25mm F4 AL | SMC Pentax-D FA 645 55mm F2.8 AL | Pentax 90mm f/2.8 D FA 645 Macro ED AW SR | SMC Pentax-D FA 645 200mm f/4 IF | SMC Pentax-D FA 645 300mm f/4 ED IF | SMC FA 645 400mm f/5.6 ED IF Lens

  
  LOG IN TO REPLY
stevegreen
THREAD ­ STARTER
Member
121 posts
Joined Jan 2005
Location: Shropshire, UK
     
Nov 20, 2009 09:05 |  #3

TheMissouriShooter wrote in post #9049720 (external link)
Did you set the 580EX II as a SLAVE?

Is that Custom Function 5, set as 3?

As I said I lost my instructions so need to glean info off you good people :o


Pigs? .......... In there?
My Flickr  (external link)My Gear
My Website  (external link)My Blog (external link)

  
  LOG IN TO REPLY
Big ­ G
Senior Member
Avatar
332 posts
Joined Dec 2008
Location: Bolton, UK
     
Nov 20, 2009 09:06 |  #4

PM me your email address, I have a PDF copy of the ST-E2 manual and 580 EXII manual.


S100, 1000D (My first DSLR) plus 5D and various lenses
Full Gear List
Flickr (external link)

  
  LOG IN TO REPLY
stevegreen
THREAD ­ STARTER
Member
121 posts
Joined Jan 2005
Location: Shropshire, UK
     
Nov 20, 2009 09:09 as a reply to  @ stevegreen's post |  #5

Actually, just got it.........press and hold the zoom button and then you get the option, master or slave..........:cool:

Time for this post to sink to the depths but may be useful for people searching :)


Pigs? .......... In there?
My Flickr  (external link)My Gear
My Website  (external link)My Blog (external link)

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

1,175 views & 0 likes for this thread
ST-E2 won't fire my 580EXII - Any ideas?
FORUMS General Gear Talk Flash and Studio Lighting 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is MarisaRachelle
1061 guests, 228 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.