Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses 
Thread started 08 Jul 2011 (Friday) 20:42
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

Sigma 50mm issues....anybody else this lucky? :))

 
aboss3
Goldmember
Avatar
2,616 posts
Joined Jan 2010
Location: LOS ANGELES
     
Jul 08, 2011 20:42 |  #1
bannedPermanent ban

Received my 2nd copy of Sigma 50mm today, and it's soft & front-focusing again. Ohh well....this time it goes to NY for repairs.
Anybody else having the same luck nowadays with 50's ?

My previous copy came from Abe's during their specials sale and went right back. This one is from Amazon. So those who are thinking about ordering one, beware as this may be a bad badge.


Gear | My gear is changing faster than I can update the signature
VoyageEyewear (external link)

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
ShotByTom
Goldmember
Avatar
3,042 posts
Gallery: 23 photos
Likes: 132
Joined Aug 2005
Location: Indianapolis
     
Jul 08, 2011 21:18 |  #2

I bought mine from B&H about two months ago. I called Sigma and they actually said it's best to send it to them for calibration because there's no guarantee that another lens from B&H wouldn't have issues as well.

Now that it's calibrated though, I love it, Well worth the money!

Make sure you call Sigma the day they receive your lens. I was told it was a one day turn-around, but mine sat on a desk for a week before they fixed it.


Gear
Website (external link)

  
  LOG IN TO REPLY
rxjohn
Goldmember
Avatar
1,072 posts
Likes: 29
Joined Nov 2006
Location: Northern Cal
     
Jul 08, 2011 21:55 as a reply to  @ ShotByTom's post |  #3

knock on wood, call me lucky.

My copy works just fine. Great lens.




  
  LOG IN TO REPLY
vitacura
Goldmember
Avatar
1,514 posts
Joined Nov 2009
Location: Tampa Bay, Fl
     
Jul 08, 2011 22:01 |  #4

This is a known issue with the Sigmalux. I also had to send mine in for calibration, twice actually, but it came back spot on and I absolutely love the lens!


Gear & Feedback

  
  LOG IN TO REPLY
TriangleZ
Member
79 posts
Joined Apr 2011
     
Jul 08, 2011 22:01 |  #5

My first one was FF so I exchanged for new one through B&H hoping my 2nd one would be spot on. I was wrong. I just sent it into Sigma and I'm waiting for it to come back...hopefully it'll be good. I do wonder, if I don't send in my t2i body, how would they know how much to calibrate? Because I hear all bodies are slightly different.




  
  LOG IN TO REPLY
coolchu001
Senior Member
279 posts
Joined May 2011
     
Jul 08, 2011 22:16 |  #6

I ended up returning my copy to Abes of maine. MA didn't fix the soft focus. Going to use the canon 50mm 1.4 instead.... the sigma was a great lens if it focused properly...


Gearlist|Feedback|For Sale

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

794 views & 0 likes for this thread
Sigma 50mm issues....anybody else this lucky? :))
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is vini81
613 guests, 267 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.