Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS General Gear Talk Flash and Studio Lighting 
Thread started 27 Jul 2011 (Wednesday) 16:39
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

RF-602 Receiver Not turning on

 
r34p3rex
Member
192 posts
Joined Jan 2010
Location: New York/Boston
     
Jul 27, 2011 16:39 |  #1

I just got a RF-602 a few days back and now it seems the receiver won't turn on. I tried new batteries (tested with voltage meter) and it still won't turn on. I remember there being a red light on the receiver, but now it just remains off.

Is this receiver broken?

EDIT: When I plug the receiver into the sync port of my AB800, it will trigger the flash (only once though).


Gripped 5DII | 24-105 f/4L | 70-200 f/2.8L | Sigma 180mm f/3.5 Macro | 430EX II
AB800 | YN-602RF | Vagabond Mini
My Feedback (on other sites): Overclock.net (external link) | Pbnation (external link)

  
  LOG IN TO REPLY
110yd
Senior Member
784 posts
Likes: 29
Joined Jan 2005
     
Jul 27, 2011 18:25 |  #2

r34p3rex wrote in post #12833422 (external link)
I just got a RF-602 a few days back and now it seems the receiver won't turn on. I tried new batteries (tested with voltage meter) and it still won't turn on. I remember there being a red light on the receiver, but now it just remains off.

Is this receiver broken?

EDIT: When I plug the receiver into the sync port of my AB800, it will trigger the flash (only once though).

I have seen similar problems with RF-602 triggers. The contacts for the battery can easily get bent. Check to see that the battery is actually making a good electrical contact.

Regards

110yd




  
  LOG IN TO REPLY
watt100
Cream of the Crop
14,021 posts
Likes: 29
Joined Jun 2008
     
Jul 28, 2011 05:23 |  #3

110yd wrote in post #12833940 (external link)
Check to see that the battery is actually making a good electrical contact.

yes, definitively check this ^




  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

837 views & 0 likes for this thread
RF-602 Receiver Not turning on
FORUMS General Gear Talk Flash and Studio Lighting 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is m.nobles
857 guests, 179 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.