Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon G-series Digital Cameras 
Thread started 28 Jul 2011 (Thursday) 11:28
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

Slight problem with g10

 
peterbj7
Goldmember
3,123 posts
Likes: 1
Joined Oct 2007
Location: A Caribbean island in Belize and occasionally UK
     
Jul 28, 2011 11:28 |  #1

Picking up my G10 yesterday I noticed that the front cover that forms the finger grip is slightly loose - it has maybe 1/5mm movement in and out. The only screw I can find that apparently holds this plastic cover is on the right side of the camera and is tight. There are very few visible screws anywhere on the camera and they're all tight. Anyone any ideas?


5D & 7D (both gripped), 24-105L, 100-400L, 15-85, 50 f1.8, Tamron 28-75, Sigma 12-24, G10, EX-Z55 & U/W housing, A1+10 lenses, tripods, lighting gear, etc. etc.
"I prefer radio to television. The pictures are better"

  
  LOG IN TO REPLY
donbga
Member
171 posts
Joined Jan 2007
     
Jul 28, 2011 20:05 |  #2

peterbj7 wrote in post #12837663 (external link)
Picking up my G10 yesterday I noticed that the front cover that forms the finger grip is slightly loose - it has maybe 1/5mm movement in and out. The only screw I can find that apparently holds this plastic cover is on the right side of the camera and is tight. There are very few visible screws anywhere on the camera and they're all tight. Anyone any ideas?

I assume since it's a G10 it's used. If so see if you can, return it to the seller. If new it's under warranty.

If you can't return the camera to the seller sounds like it's time to return it to the mother ship. Nothing is supposed to feel loose on the case.




  
  LOG IN TO REPLY
peterbj7
THREAD ­ STARTER
Goldmember
3,123 posts
Likes: 1
Joined Oct 2007
Location: A Caribbean island in Belize and occasionally UK
     
Jul 28, 2011 20:45 |  #3

Not used or new - I bought it new several years ago when they were the current model. It was and still is a superb camera, with just this slight niggle.


5D & 7D (both gripped), 24-105L, 100-400L, 15-85, 50 f1.8, Tamron 28-75, Sigma 12-24, G10, EX-Z55 & U/W housing, A1+10 lenses, tripods, lighting gear, etc. etc.
"I prefer radio to television. The pictures are better"

  
  LOG IN TO REPLY
hfgarris
Goldmember
Avatar
1,760 posts
Likes: 11
Joined Feb 2009
Location: Cedar Rapids, Iowa
     
Aug 02, 2011 14:43 |  #4

It appears that there may be another screw inside the connector cover on that same side which may attach to a part of the front cover. You might check to see if it is missing or loose.




  
  LOG IN TO REPLY
peterbj7
THREAD ­ STARTER
Goldmember
3,123 posts
Likes: 1
Joined Oct 2007
Location: A Caribbean island in Belize and occasionally UK
     
Aug 02, 2011 18:10 |  #5

I'll check that. Thanks.


5D & 7D (both gripped), 24-105L, 100-400L, 15-85, 50 f1.8, Tamron 28-75, Sigma 12-24, G10, EX-Z55 & U/W housing, A1+10 lenses, tripods, lighting gear, etc. etc.
"I prefer radio to television. The pictures are better"

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

1,186 views & 0 likes for this thread
Slight problem with g10
FORUMS Canon Cameras, Lenses & Accessories Canon G-series Digital Cameras 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is Thingsyettobe
560 guests, 187 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.