Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras 
Thread started 26 Aug 2011 (Friday) 10:50
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

Camera didn't turn on first time

 
Frugal
Senior Member
Avatar
784 posts
Joined May 2009
Location: Northern CA
     
Aug 26, 2011 10:50 |  #1

At the start of shooting a community event I turned my 50D on and nothing. Aaarg! I popped the battery out and re-inserted it and then it was fine. Battery was Canon brand and fully charged and I'd test fired the camera before leaving home. Camera bag is well padded. I baby it. I've tried to make it happen again but the battery door has to be clicked open for it to turn off and I'd swear it was fully closed. Since I use it in my business is there anything I should do other than always have a backup camera with me? - clean terminals etc?


Richard
Gear

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
number ­ six
fully entitled to be jealous
Avatar
8,953 posts
Likes: 85
Joined May 2007
Location: SF Bay Area
     
Aug 26, 2011 14:41 |  #2

As you know, there's a microswitch on the battery door. There's also one on the CF card door. Could that have been the problem?

-js


"Be seeing you."
50D - 17-55 f/2.8 IS - 18-55 IS - 28-105 II USM - 60 f/2.8 macro - 70-200 f/4 L - Sigma flash

  
  LOG IN TO REPLY
Hard ­ Drive ­ Disk
Senior Member
Avatar
485 posts
Joined Jul 2011
     
Aug 26, 2011 14:43 |  #3

I feel like I've had this problem. Should be fine.


Gear List
I Love ThinkTank
Is It Normal for Me to Have 7 Camera Bags?

  
  LOG IN TO REPLY
Frugal
THREAD ­ STARTER
Senior Member
Avatar
784 posts
Joined May 2009
Location: Northern CA
     
Aug 26, 2011 14:58 |  #4

number six wrote in post #13004837 (external link)
As you know, there's a microswitch on the battery door. There's also one on the CF card door. Could that have been the problem?

-js

I didn't see that it was open but thanks

I feel like I've had this problem. Should be fine.

Thanks. That's reassuring.


Richard
Gear

  
  LOG IN TO REPLY
oldvultureface
Goldmember
Avatar
4,270 posts
Gallery: 81 photos
Best ofs: 2
Likes: 347
Joined Jun 2008
Location: Northwest Indiana USA
     
Aug 26, 2011 17:49 as a reply to  @ Frugal's post |  #5

Same here. It happened to me a few weeks ago after pulling the battery to recharge. Removed and reinserted it and all has been well since.




  
  LOG IN TO REPLY
KenjiS
"Holy crap its long!"
Avatar
21,388 posts
Gallery: 572 photos
Likes: 2720
Joined Oct 2008
Location: Buffalo, NY
     
Aug 26, 2011 18:36 |  #6

Nah, They just activated the 50D's killswitch, thats all, in 2 months it will explode forcing you to upgrade

its part of Canon's secret initiative to boost sales...

(In all honesty, probubly just a fluke, a bit of dirt or something in one of the little microswitches in the battery door, Probably nothing to panic about)


Gear, New and Old! RAW Club Member
Wanted: 70-200. Time and good health
Deviantart (external link)
Flickr (This is where my good stuff is!) (external link)

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

789 views & 0 likes for this thread
Camera didn't turn on first time
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is ArcticRose
727 guests, 295 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.