Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses 
Thread started 12 Dec 2011 (Monday) 23:13
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

IS failure?

 
Simpleboy
Member
197 posts
Joined Aug 2007
     
Dec 12, 2011 23:13 |  #1

So i've had my 70-200f4 IS since the day it came out and its been perfect. However, recently about every 3rd or 4th time i use it with the IS it looks like theres a squirrel on coffee with a jackhammer deciding what the IS does. The image really shakes that much. Far more than not using the IS!

Has anyone had this problem before? Did you seek replacement or repair? If you repaired, how much did it cost?

Thanks for any help.




  
  LOG IN TO REPLY
kawi_200
Goldmember
1,460 posts
Gallery: 9 photos
Likes: 138
Joined Jul 2011
Location: Stanwood, WA
     
Dec 12, 2011 23:15 |  #2

Is it only when IS first starts up and the elements jump? Or is it a constant jackhammer the entire time?


5D4 | 8-15L | 28-135mm f/3.5-5.6 IS | 24L II | 40mm pancake | 100L IS | 70-200mm f/2.8L IS mk2 | 400mm f/4 DO IS

  
  LOG IN TO REPLY
Simpleboy
THREAD ­ STARTER
Member
197 posts
Joined Aug 2007
     
Dec 12, 2011 23:45 |  #3

Its the whole time the IS is working. But when it happens i usually stop using IS pretty quick! If i turn the camera off and on again, it'll be fine, then a wee way down the track, it'll be jackhammering again.




  
  LOG IN TO REPLY
kawi_200
Goldmember
1,460 posts
Gallery: 9 photos
Likes: 138
Joined Jul 2011
Location: Stanwood, WA
     
Dec 13, 2011 00:38 |  #4

Definitly sounds like something with the IS went bad. I can't really help you there. Sorry it happened :(


5D4 | 8-15L | 28-135mm f/3.5-5.6 IS | 24L II | 40mm pancake | 100L IS | 70-200mm f/2.8L IS mk2 | 400mm f/4 DO IS

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

658 views & 0 likes for this thread
IS failure?
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is Rerrariworks2021
1228 guests, 266 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.