Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses 
Thread started 17 Sep 2012 (Monday) 13:11
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

New Sigma 35mm f/1.4 HSM DG

 
syclarac
Member
148 posts
Likes: 2
Joined Jan 2012
Location: San Francisco Bay Area
     
Jun 25, 2013 12:48 |  #3151

My two year old with Canon 5D Mark II + Sigma 35mm 1.4

IMAGE: http://farm8.staticflickr.com/7379/9134676795_bd074e2c67_b.jpg

www.suechoiphotography​.com (external link)
6D, 5D2, ∑15mm fisheye, 16-35 f2.8IIL, 50L, 100L macro
T3i, 17-55 f2.8, 50 f1.8

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
drmaxx
Goldmember
1,144 posts
Gallery: 29 photos
Likes: 357
Joined Jul 2010
     
Jun 25, 2013 14:52 as a reply to  @ syclarac's post |  #3152

I am 'late' in the game and just pulled the trigger for the 35mm. I just barely had some moments to take some very few test shots. Very good first impression and it seems that I don't have any focus issues with my copy of the lens.

So far a happy camper - let's see what the next few days will bring.

Thanks for all the info in this thread - very helpful for my final decision making.

Does anybody has any info on the firmware update?


Donate if you love POTN

  
  LOG IN TO REPLY
carpenter
Goldmember
2,610 posts
Gallery: 12 photos
Likes: 294
Joined Jul 2006
Location: Green Bay, WI
     
Jun 25, 2013 20:52 |  #3153

JNowakPhoto wrote in post #16032138 (external link)
Looks like mine needed the following adj:

0.3 +10
0.4 +11
0.6 +12
Inf +1

weird........



about identical with what mine is.


5D Mk IV | 24-105L | 85 1.8 | 70-200L 2.8 IS MkII | 100-400L MkII

  
  LOG IN TO REPLY
Arob1000
Senior Member
Avatar
823 posts
Gallery: 1 photo
Likes: 5
Joined May 2012
Location: Los Angeles, CA
     
Jun 25, 2013 21:06 |  #3154

carpenter wrote in post #16065069 (external link)
about identical with what mine is.

Thanks, going to pick one up from Adorama, they finally have it in stock.


Website (external link) :cool:500px (external link) :cool: Flickr (external link) :cool: Facebook (external link) :cool:Blog (external link):cool:

  
  LOG IN TO REPLY
M.A.R.K.O
Junior Member
Avatar
23 posts
Likes: 3
Joined Jun 2013
Location: Tallinn, Estonia
     
Jun 26, 2013 04:29 |  #3155

I tested two copies of this lens few months ago inside and outside the store on my 1DsII. Optically they were brilliant but AF was inconsistent on both of them.
At closer distances they focused mostly pretty accurately, but at longer distances most of the photos were completely out of focus @f1.4.
It makes me sad beacuse I really wanted to buy this lens.

PS I've had the same unpleasent experience with several copies of Sigma 50mm f1.4 too.
None of my Canon primes have never had any AF accuracy problems.


Marko
http://www.msphotoline​.com (external link)
1Ds II | Σ35A | 85L II | 135L | EF 1.4X III | 580EX II x 2 | YN-622C x 3

  
  LOG IN TO REPLY
igora90
Senior Member
923 posts
Likes: 82
Joined Dec 2011
Location: Rovaniemi, Finland
     
Jun 26, 2013 04:50 |  #3156

seanp3 wrote in post #16062353 (external link)
How does this lens focus with older bodies. Anyone using this lens with the 5dc?

I'm using it and it's spot on!


2x Canon 6D, Sigma 35mm f/1.4, Sigma 50mm f/1.4 ART, EF 85mm f/1.8, EF 135 F/2.0
www.iirorautiainen.com (external link)
Flickr (external link)
Facebook (external link)

  
  LOG IN TO REPLY
drzenitram
Senior Member
824 posts
Joined Aug 2012
     
Jun 26, 2013 09:46 |  #3157

M.A.R.K.O wrote in post #16065829 (external link)
I tested two copies of this lens few months ago inside and outside the store on my 1DsII. Optically they were brilliant but AF was inconsistent on both of them.
At closer distances they focused mostly pretty accurately, but at longer distances most of the photos were completely out of focus @f1.4.
It makes me sad beacuse I really wanted to buy this lens.

PS I've had the same unpleasent experience with several copies of Sigma 50mm f1.4 too.
None of my Canon primes have never had any AF accuracy problems.

Sounds like you've been lucky with Canon! Does that store have the sigma USB dock? You ought to see if they would be willing to calibrate a lens for you.


| Bodies - 5D Mark II, T2i | Lenses - Helios 44-2, Sigma 35mm 1.4, Sigma 85 1.4, Sigma 70-200 2.8 OS, Tamron SP AF 1.4x TC | Lights - 430ex ii x2, Random 3rd party strobes

  
  LOG IN TO REPLY
Vixen89
Goldmember
Avatar
4,521 posts
Likes: 13
Joined Aug 2010
Location: D-Town, TX
     
Jun 26, 2013 09:53 |  #3158

M.A.R.K.O wrote in post #16065829 (external link)
I tested two copies of this lens few months ago inside and outside the store on my 1DsII. Optically they were brilliant but AF was inconsistent on both of them.
At closer distances they focused mostly pretty accurately, but at longer distances most of the photos were completely out of focus @f1.4.
It makes me sad beacuse I really wanted to buy this lens.

PS I've had the same unpleasent experience with several copies of Sigma 50mm f1.4 too.
None of my Canon primes have never had any AF accuracy problems.

I wouldn't give up til the lens has been on that USB dock and tested again.


I'm actively lazy!! :D | Gear List | photovxn.com (under construction)external link

  
  LOG IN TO REPLY
carpenter
Goldmember
2,610 posts
Gallery: 12 photos
Likes: 294
Joined Jul 2006
Location: Green Bay, WI
     
Jun 26, 2013 10:06 |  #3159

Vixen89 wrote in post #16066401 (external link)
I wouldn't give up til the lens has been on that USB dock and tested again.

yup, with no dock I'd have sent mine back. It's somewhat disappointing that it should need 4 levels of adjustment in the first place as you'd think the QC or manufacturing would have things shored up a bit more than that, but that said, it is one damn amazing lens once dialed in.


5D Mk IV | 24-105L | 85 1.8 | 70-200L 2.8 IS MkII | 100-400L MkII

  
  LOG IN TO REPLY
M.A.R.K.O
Junior Member
Avatar
23 posts
Likes: 3
Joined Jun 2013
Location: Tallinn, Estonia
     
Jun 26, 2013 11:05 |  #3160

drzenitram wrote in post #16066380 (external link)
Sounds like you've been lucky with Canon! Does that store have the sigma USB dock? You ought to see if they would be willing to calibrate a lens for you.

When I tested those lenses the store did not have the USB dock. Maybe now they have it, I have to check. If they can calibrte the lens with the USB dock then I will defenitely give it another try.


Marko
http://www.msphotoline​.com (external link)
1Ds II | Σ35A | 85L II | 135L | EF 1.4X III | 580EX II x 2 | YN-622C x 3

  
  LOG IN TO REPLY
Mareckik
Member
141 posts
Likes: 134
Joined Dec 2012
Location: POLAND
     
Jun 26, 2013 14:36 as a reply to  @ M.A.R.K.O's post |  #3161

Hi.
I just found strange issue. With 5dmkII in LiveView I cannot use digital zoom function. Do you guys also have same problem, or only I have.
With 7d my Sigma works normally.


I'm still learning... English:cool:
MKstudio (external link)
SmugMug (external link)
5dmkII / 2x 6d / 7d / EF 70-200 2.8 IS USM II / EF 135mm f2 / Sigma 85 1.4 / Sigma 50 1.4 ART / Sigma 35 1.4 ART / EF 17-40 / YN-568EX / YN-560EX / YN-622C / Tamrac / Lowepro / Eizo / x-rite / Sandisk

  
  LOG IN TO REPLY
drzenitram
Senior Member
824 posts
Joined Aug 2012
     
Jun 26, 2013 21:09 |  #3162

Mareckik wrote in post #16067227 (external link)
Hi.
I just found strange issue. With 5dmkII in LiveView I cannot use digital zoom function. Do you guys also have same problem, or only I have.
With 7d my Sigma works normally.

Try it with other lenses on the 5d2? I'm sure it doesn't have anything to do with the sigma, probably just a setting.


| Bodies - 5D Mark II, T2i | Lenses - Helios 44-2, Sigma 35mm 1.4, Sigma 85 1.4, Sigma 70-200 2.8 OS, Tamron SP AF 1.4x TC | Lights - 430ex ii x2, Random 3rd party strobes

  
  LOG IN TO REPLY
Mareckik
Member
141 posts
Likes: 134
Joined Dec 2012
Location: POLAND
     
Jun 27, 2013 02:03 |  #3163

drzenitram wrote in post #16068321 (external link)
Try it with other lenses on the 5d2? I'm sure it doesn't have anything to do with the sigma, probably just a setting.

With my other lens, LV zoom works normally


I'm still learning... English:cool:
MKstudio (external link)
SmugMug (external link)
5dmkII / 2x 6d / 7d / EF 70-200 2.8 IS USM II / EF 135mm f2 / Sigma 85 1.4 / Sigma 50 1.4 ART / Sigma 35 1.4 ART / EF 17-40 / YN-568EX / YN-560EX / YN-622C / Tamrac / Lowepro / Eizo / x-rite / Sandisk

  
  LOG IN TO REPLY
Scott_1469
Senior Member
Avatar
783 posts
Likes: 1
Joined Jan 2007
Location: Minneapolis, MN
     
Jun 27, 2013 07:43 |  #3164

Mareckik wrote in post #16067227 (external link)
Hi.
I just found strange issue. With 5dmkII in LiveView I cannot use digital zoom function. Do you guys also have same problem, or only I have.
With 7d my Sigma works normally.

Just doublechecked and digital zoom in LiveView works perfectly fine with the 35 on my 5Dii.


Gear List | My Flickr Site (external link)
Quote from my oldest: "Dad, I liked you a lot better when you had the small camera"

  
  LOG IN TO REPLY
drzenitram
Senior Member
824 posts
Joined Aug 2012
     
Jun 27, 2013 09:55 |  #3165

Mareckik wrote in post #16068830 (external link)
With my other lens, LV zoom works normally

That's really strange, digital zoom has nothing to do with the lens, it's just cropping and digitally enlarging a certain part of the image, I can digital zoom with manual focus lenses that have no communication with the camera.


| Bodies - 5D Mark II, T2i | Lenses - Helios 44-2, Sigma 35mm 1.4, Sigma 85 1.4, Sigma 70-200 2.8 OS, Tamron SP AF 1.4x TC | Lights - 430ex ii x2, Random 3rd party strobes

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

661,228 views & 2 likes for this thread
New Sigma 35mm f/1.4 HSM DG
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is beerman2
1104 guests, 285 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.