Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Forums  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear
Guest
Forums  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear
Register to forums    Log in

 
FORUMS Cameras, Lenses & Accessories Canon Digital Cameras 
Thread started 06 Jul 2013 (Saturday) 08:31
Search threadPrev/next
sponsored links (only for non-logged)

5D MKII Problems, need help

 
Sublime1304
Hatchling
5 posts
Joined May 2013
Location: Warminster, PA
     
Jul 06, 2013 08:31 |  #1

Ok so I just bought a 5D MKII yesterday and today I was about to use it and at startup I am getting an error 80, nothing else powers on. So I took the battery out and now its fine. A few shots in and I get the error again and it fails to release the shutter and all of the buttons dont work. Repeat the process, sometimes it works and sometimes it doesn't. Sometimes the camera wont startup at all and by that i mean no error, just nothing turns on. Another thing im experiencing is sometimes when i do turn the camera on, the top lcd turns on but when i push a button it will flash "busy" forever"

What can I do and is their a fix for it? The camera has a very low shutter count and its almost brand new. Bought it used. My memory cards seem to write fine, I use 8GB Sandisk Ultra cards and my batteries are all authentic LP-E6. Someone help me. Thanks


Mike Burns - Mike Burns Photography (external link)
Flickr (external link)
Canon 5D MKII, Canon 17-40mm F4L, Canon 85mm f/1.8, Canon 35mm f/2.

  
  LOG IN TO REPLY
brucea
Senior Member
620 posts
Gallery: 28 photos
Likes: 280
Joined Oct 2004
     
Jul 06, 2013 08:57 |  #2

error is attributable variously to memory cards and batteries.

https://photography-on-the.net …/showthread.php​?t=1171278

see the bottom of this page also:

http://www.canon-europe.com …13-917361&page=1&type=faq (external link)

and this one

http://www.fredmiranda​.com/forum/topic/11572​53 (external link)




  
  LOG IN TO REPLY
Sublime1304
THREAD ­ STARTER
Hatchling
5 posts
Joined May 2013
Location: Warminster, PA
     
Jul 06, 2013 09:14 |  #3

But if that is a primary reason, why would my camera not startup at all. Batteries are fully charged btw. And I havent had any corrupted pictures or any problem with photos writing to the card. Im stumped. Just dropped $1500 on this camera and this is very annoying


Mike Burns - Mike Burns Photography (external link)
Flickr (external link)
Canon 5D MKII, Canon 17-40mm F4L, Canon 85mm f/1.8, Canon 35mm f/2.

  
  LOG IN TO REPLY
Tommy1957
Goldmember
1,288 posts
Joined Apr 2013
     
Jul 06, 2013 12:17 |  #4

I had similar problems with a 5D I bought used. My solution? I used a pencil eraser to clean all the electrical contacts. Batteries, grips, body, all of it. Haven't had an issue since.




  
  LOG IN TO REPLY
sponsored links (only for non-logged)

699 views & 0 likes for this thread, 3 members have posted to it.
5D MKII Problems, need help
FORUMS Cameras, Lenses & Accessories Canon Digital Cameras 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Forums   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset   •  Home

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.58forum software
version 2.58 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is trempulant
914 guests, 116 members online
Simultaneous users record so far is 15,144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.