Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses 
Thread started 19 Feb 2014 (Wednesday) 12:18
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

Sigma 35mm Art not recognized on my 5D3/LR5?

 
pstyle1
Senior Member
Avatar
317 posts
Joined Jun 2012
Location: DC/VA
     
Feb 19, 2014 12:18 |  #1

Hi All,

I just got a Sigma 35mm 1.4 Art lens and noticed that in the camera (5D3) and in lightroom 5 it's just recognized as "35mm". This is my first third-party lens so I'm not sure if this is normal? I'm used to seeing all the lens info both in camera and in lightroom.

The AF and metering seem to work just fine.


5D MkIII x2 + a lot of L's.
www.facebook.com/Peyma​nRazaviPhotography (external link)

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
John ­ from ­ PA
Cream of the Crop
8,990 posts
Likes: 757
Joined May 2003
Location: Southeast Pennsylvania
     
Feb 19, 2014 13:18 |  #2

I think what you describe is normal in that the camera can't recognize 3rd party lenses, only those made by Canon. When I shoot with a Sigma 17-50 f2.8 it only appears in the EXIF as 17-50mm. The same is likely with lightroom, since it most likely derives its information from the EXIF.

I'm used to seeing all the lens info both in camera and in lightroom.

I'd go back and check some of those instances and I suspect they are likely with Canon lenses (which do work fine for me).




  
  LOG IN TO REPLY
Sirrith
Cream of the Crop
10,545 posts
Gallery: 50 photos
Best ofs: 1
Likes: 36
Joined Nov 2010
Location: Hong Kong
     
Feb 19, 2014 17:50 |  #3

LR 5.3 will recognize it.


-Tom
Flickr (external link)
F-Stop Guru review | RRS BH-40 review

  
  LOG IN TO REPLY
John ­ from ­ PA
Cream of the Crop
8,990 posts
Likes: 757
Joined May 2003
Location: Southeast Pennsylvania
     
Feb 20, 2014 07:04 |  #4

Sirrith wrote in post #16702496 (external link)
LR 5.3 will recognize it.

Any idea where LR5 gets the information? I have looked at some of my images (both RAW & JPG) with several EXIF "viewers" and not a single one gets it right with images taken with my Sigma 17-50 (about 2 years old). All get it correct whenever a Canon lens is mounted. Most viewers simply have a generic description (with the Sigma) but one online viewer reports the lens as a Canon EF 85mm f/1.2L (I wish) :).




  
  LOG IN TO REPLY
Sirrith
Cream of the Crop
10,545 posts
Gallery: 50 photos
Best ofs: 1
Likes: 36
Joined Nov 2010
Location: Hong Kong
     
Feb 20, 2014 09:51 |  #5

No idea, sorry!


-Tom
Flickr (external link)
F-Stop Guru review | RRS BH-40 review

  
  LOG IN TO REPLY
mikeinctown
Goldmember
2,100 posts
Likes: 228
Joined May 2012
Location: Cleveland, Ohio
     
Feb 20, 2014 14:44 |  #6

When I had lightroom 5 beta on my computer, it would see the same thing as the camera did. Just a basic 35mm lens.




  
  LOG IN TO REPLY
Legion5
Member
84 posts
Joined May 2010
     
Feb 20, 2014 19:29 |  #7

pstyle1 wrote in post #16701682 (external link)
Hi All,

I just got a Sigma 35mm 1.4 Art lens and noticed that in the camera (5D3) and in lightroom 5 it's just recognized as "35mm". This is my first third-party lens so I'm not sure if this is normal? I'm used to seeing all the lens info both in camera and in lightroom.

The AF and metering seem to work just fine.

Third party lenses are reported as generic to the camera. Canon won't allow third party manufacturers to be named in lens info only generic and canon are allowed. Lightroom added support later for third party names.




  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

1,114 views & 0 likes for this thread
Sigma 35mm Art not recognized on my 5D3/LR5?
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member was a spammer, and banned as such!
872 guests, 209 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.