Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses 
Thread started 08 Apr 2014 (Tuesday) 12:57
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

Canon 50mm F1.4 Dropped :( <moved>

 
ppmax
Member
170 posts
Likes: 32
Joined Feb 2009
     
Apr 08, 2014 12:57 |  #1

I recently dropped my 50 f1.4 and now the aperture blades are stuck (my cameras report "Communication error" with the lens when I take a shot). If I select wide open aperture the lens works, but it's clear something is busted in the lens.

The lens is out of warranty and I'd rather not send it to Canon...can shops like Mike's fix stuff like this? Is it worth repairing?

thx
PP


Canon 1DX Mark II, EF 100-400 f/4.5-5.6 IS USM Mark II, EF 70-200mm f/4L IS USM, EF 24-105mm f/4L IS USM, EF 50mm f/1.4
Rokinon 85mm f/1.4 AS IF, 14mm f/2.8 ED AS IF UMC

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
John ­ from ­ PA
Cream of the Crop
8,966 posts
Likes: 751
Joined May 2003
Location: Southeast Pennsylvania
     
Apr 08, 2014 13:01 |  #2

ppmax wrote in post #16819111 (external link)
The lens is out of warranty and I'd rather not send it to Canon...can shops like Mike's fix stuff like this? Is it worth repairing?

Who is Mike? Have you asked him?




  
  LOG IN TO REPLY
ppmax
THREAD ­ STARTER
Member
170 posts
Likes: 32
Joined Feb 2009
     
Apr 08, 2014 13:22 |  #3

http://mikescamera.com (external link)
http://mikescamera.com​/contact-info.html (external link)

I haven't asked "Mike" yet...I would like to not ask if anyone may have inquired before and have been:
a) ...told they don't fix lenses
b) ...were unsatisfied with their work

thx--
PP


Canon 1DX Mark II, EF 100-400 f/4.5-5.6 IS USM Mark II, EF 70-200mm f/4L IS USM, EF 24-105mm f/4L IS USM, EF 50mm f/1.4
Rokinon 85mm f/1.4 AS IF, 14mm f/2.8 ED AS IF UMC

  
  LOG IN TO REPLY
TeamSpeed
01010100 01010011
Avatar
36,140 posts
Gallery: 105 photos
Best ofs: 2
Likes: 5354
Joined May 2002
Location: Midwest
     
Apr 08, 2014 13:52 as a reply to  @ ppmax's post |  #4

I would be afraid that one of the handful of ribbon cables has snapped. The lens is a bit tricky to take apart, but with the right tools, it is more an exercise in patience, than skill.


Past Equipment | My Personal Gallery (external link) My Business Gallery (external link)
For Sale: Sigma USB Dock
For Sale: Ladies Thirty-One Camera Sling

  
  LOG IN TO REPLY
pwm2
"Sorry for being a noob"
Avatar
8,626 posts
Likes: 3
Joined May 2007
Location: Sweden
     
Apr 08, 2014 14:01 |  #5

ppmax wrote in post #16819111 (external link)
I recently dropped my 50 f1.4 and now the aperture blades are stuck (my cameras report "Communication error" with the lens when I take a shot). If I select wide open aperture the lens works, but it's clear something is busted in the lens.

The lens is out of warranty and I'd rather not send it to Canon...can shops like Mike's fix stuff like this? Is it worth repairing?

thx
PP

Are you aware that you don't specify where you live? This world can have lots of companies named Mike's - or multiple chains named Mike's. So it really isn't easy for people from all over the world to be sure they know what shop or chain of shops you are talking about.


5DMk2 + BG-E6 | 40D + BG-E2N | 350D + BG-E3 + RC-1 | Elan 7E | Minolta Dimage 7U | (Gear thread)
10-22 | 16-35/2.8 L II | 20-35 | 24-105 L IS | 28-135 IS | 40/2.8 | 50/1.8 II | 70-200/2.8 L IS | 100/2.8 L IS | 100-400 L IS | Sigma 18-200DC
Speedlite 420EZ | Speedlite 580EX | EF 1.4x II | EF 2x II

  
  LOG IN TO REPLY
TeamSpeed
01010100 01010011
Avatar
36,140 posts
Gallery: 105 photos
Best ofs: 2
Likes: 5354
Joined May 2002
Location: Midwest
     
Apr 08, 2014 18:16 |  #6

The same question was asked and answered though.


Past Equipment | My Personal Gallery (external link) My Business Gallery (external link)
For Sale: Sigma USB Dock
For Sale: Ladies Thirty-One Camera Sling

  
  LOG IN TO REPLY
ppmax
THREAD ­ STARTER
Member
170 posts
Likes: 32
Joined Feb 2009
     
Apr 08, 2014 18:31 |  #7

TeamSpeed wrote in post #16819265 (external link)
I would be afraid that one of the handful of ribbon cables has snapped. The lens is a bit tricky to take apart, but with the right tools, it is more an exercise in patience, than skill.

Interesting...the "drop" was really just a minor "fling" out of my camera bag as I pulled it from the car...and the landing wasn't really vertical...I can't imagine a ribbon cable would break because of this but I'm really just speculating.

With the lens mounted and while pushing the DOF preview button on my 5D3 I can hear a little motor(?) emit a little "whiz"..so there is some electrical current reaching something related to the aperture. I also have a plastic fantastic 50 and I tried the same thing...I get a little "whiz" when engaging the DOF preview button. Assuming the lens mechanicals are roughly similar, it appears that something is working consistently across the two lenses.

I'm half tempted to pry the thing apart and see what I can find...but (assuming something is broken rather than stuck) I'd rather get a fix, assuming the repair cost isn't over $100 or so.

Anyone have a lens repaired before? Roughly speaking what does it cost?

thx
PP


Canon 1DX Mark II, EF 100-400 f/4.5-5.6 IS USM Mark II, EF 70-200mm f/4L IS USM, EF 24-105mm f/4L IS USM, EF 50mm f/1.4
Rokinon 85mm f/1.4 AS IF, 14mm f/2.8 ED AS IF UMC

  
  LOG IN TO REPLY
TeamSpeed
01010100 01010011
Avatar
36,140 posts
Gallery: 105 photos
Best ofs: 2
Likes: 5354
Joined May 2002
Location: Midwest
     
Apr 08, 2014 18:51 |  #8

The 50 1.8 looks nothing like the 50 1.4, but have fun!

I have pulled many a 50mm apart, and fixed the stuck AF issues they have. It only take about 10 minutes to pull all the parts out.


Past Equipment | My Personal Gallery (external link) My Business Gallery (external link)
For Sale: Sigma USB Dock
For Sale: Ladies Thirty-One Camera Sling

  
  LOG IN TO REPLY
ppmax
THREAD ­ STARTER
Member
170 posts
Likes: 32
Joined Feb 2009
     
Apr 08, 2014 20:10 |  #9

Thanks TeamSpeed--much appreciated.

In your adventures these 50mm's have you encountered stuck aperture blades before? I"ve seen lots on the net about stuck focusing but nothing about stuck blades...

thx
PP


Canon 1DX Mark II, EF 100-400 f/4.5-5.6 IS USM Mark II, EF 70-200mm f/4L IS USM, EF 24-105mm f/4L IS USM, EF 50mm f/1.4
Rokinon 85mm f/1.4 AS IF, 14mm f/2.8 ED AS IF UMC

  
  LOG IN TO REPLY
TeamSpeed
01010100 01010011
Avatar
36,140 posts
Gallery: 105 photos
Best ofs: 2
Likes: 5354
Joined May 2002
Location: Midwest
     
Apr 08, 2014 20:21 |  #10

No, I haven't see stuck aperture blades. They might be mechanically stuck due to the shock, and if so, I am not sure what can be done.


Past Equipment | My Personal Gallery (external link) My Business Gallery (external link)
For Sale: Sigma USB Dock
For Sale: Ladies Thirty-One Camera Sling

  
  LOG IN TO REPLY
raptor3x
Senior Member
Avatar
728 posts
Gallery: 5 photos
Likes: 78
Joined Aug 2011
Location: Rutland, VT
     
Apr 11, 2014 09:29 |  #11

Sounds like a good reason to preorder the new Sigma 50 1.4.


Bodies: X-T1, E-M1ii, G9 Lenses: µ.Z 7-14 2.8, µ.Z 12-40 2.8, µ.Z 25 1.2, X 18-55 2.8-4, µ.Z 40-150 2.8, µ.Z 45 1.2, µ.Z 60 2.8, µ.Z 75 1.8, PL 200 2.8

  
  LOG IN TO REPLY
ppmax
THREAD ­ STARTER
Member
170 posts
Likes: 32
Joined Feb 2009
     
Apr 11, 2014 18:58 |  #12

^^ I'm hoping I won't be "forced" to do that! ;)


Canon 1DX Mark II, EF 100-400 f/4.5-5.6 IS USM Mark II, EF 70-200mm f/4L IS USM, EF 24-105mm f/4L IS USM, EF 50mm f/1.4
Rokinon 85mm f/1.4 AS IF, 14mm f/2.8 ED AS IF UMC

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

2,468 views & 0 likes for this thread
Canon 50mm F1.4 Dropped :( <moved>
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is Smoky Moments
960 guests, 302 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.