Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras 
Thread started 23 Jun 2014 (Monday) 22:02
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

5D MkI wont turn on - some repairs made.

 
ItsJustEd
Senior Member
Avatar
433 posts
Gallery: 6 photos
Likes: 20
Joined Jan 2012
Location: St. Petersburg FL
     
Jun 23, 2014 22:02 |  #1

Hello all!

So I bought a dead 5D,thinking it would be a fairly simple fix (and it may still be). When I originally looked at it I knew it had bent pins in the CF slot,and I assumed it has a blown fuse. Replaced the card slot and checked the fuse - turns out the fuse is good. Replacing the card slot didnt fix it. I have voltage inside the camera. Tested some connections on the PCB that has the fuse,got 8 volts. No water damage inside. The only thing I can think of is one of the 2 micro switches may be bad or the ribbon for those switches may be bad. The only other questionable thing is when I was removing the PCB ribbons to get the card slot out I was unlocking the tab the wrong way - kept trying to slide the locking tab down when I should have lifted it. As a result the locking tab is a little boogered up,but it still locks the ribbon down.

Any ideas what I may be missing? I got some great help from the 5D thread,but this seems to be where I can go no further.

Appreciate any insite!!


I used to think I was indecisive,but now I'm not too sure.
5DMkI 60D Canon 24-105 Canon 17-55mm Tamron 70-300
More of me http://www.flickr.com/​photos/77024467@N03/ (external link)

  
  LOG IN TO REPLY
gjl711
According to the lazy TF, My flatulence rates
Avatar
55,305 posts
Likes: 2335
Joined Aug 2006
Location: Deep in the heart of Texas
     
Jun 24, 2014 08:08 |  #2

Sounds like you really dug into it. Unfortunately I don't think there is much else you can do without starting to swap out PCBs as there are no easily serviceable parts on those. Maybe you might just re-check all of the connections?


Not sure why, but call me JJ.
I used to hate math but then I realised decimals have a point.
.
::Flickr:: (external link)
::Gear::

  
  LOG IN TO REPLY
ItsJustEd
THREAD ­ STARTER
Senior Member
Avatar
433 posts
Gallery: 6 photos
Likes: 20
Joined Jan 2012
Location: St. Petersburg FL
     
Jun 24, 2014 16:15 |  #3

gjl711 wrote in post #16991249 (external link)
Sounds like you really dug into it. Unfortunately I don't think there is much else you can do without starting to swap out PCBs as there are no easily serviceable parts on those. Maybe you might just re-check all of the connections?

Thanks JJ.

I was going to do just that. Recheck my ribbons,essentially start from scratch. I have my other 5D body from which I could change out a board or 2,but damn the thought of opening my good body,thereby acquiring the risk of having 2 dead bodies,is a lot to consider. I bought the dead unit on a whim,thinking it would be an easy fix,but the tables have turned on me.

The replacment PCB that has the boogered up ribbon clip is only $50.00,so I may do that before opening my good body. I will post my end results here and on the 5D classic board.


I used to think I was indecisive,but now I'm not too sure.
5DMkI 60D Canon 24-105 Canon 17-55mm Tamron 70-300
More of me http://www.flickr.com/​photos/77024467@N03/ (external link)

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

994 views & 0 likes for this thread
5D MkI wont turn on - some repairs made.
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is Birdie760
957 guests, 309 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.