Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras 
Thread started 14 Aug 2014 (Thursday) 18:53
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

20D suddenly stopped metering correctly

 
Nivekolleh
Hatchling
5 posts
Joined Dec 2012
     
Aug 14, 2014 18:53 |  #1

I had a problem suddenly arise on my 2004 Canon 20D. The meter started to want to over expose my pictures in bright light (outside on sunny day) but works correctly in normal light (indoors or outside on cloudy day)

Has anyone had a problem similar to this? One person on the internets suggested to change the backup battery (CR2016) which I did with no avail.

Thanks




  
  LOG IN TO REPLY
Snydremark
my very own Lightrules moment
18,495 posts
Gallery: 47 photos
Likes: 1530
Joined Mar 2009
Location: Issaquah, WA USA
     
Aug 14, 2014 19:20 |  #2

What metering mode are you using? What shooting mode (Av, Tv, M, Auto)? What subject/area are you trying to meter?


- Eric S.: My Birds/Wildlife (external link) (7D MkII/5D IV, Canon 10-22 f/3.5-4.5, Canon 24-105L f/4 IS, Canon 70-200L f/2.8 IS MkII, Canon 100-400L f/4.5-5.6 IS I/II)
"The easiest way to improve your photos is to adjust the loose nut between the shutter release and the ground."

  
  LOG IN TO REPLY
John ­ from ­ PA
Cream of the Crop
9,350 posts
Likes: 866
Joined May 2003
Location: Southeast Pennsylvania
     
Aug 15, 2014 03:30 |  #3

Post one of the outdoor pictures with the issue, and make sure the EXIF information is intact.




  
  LOG IN TO REPLY
Hermelin
Goldmember
Avatar
1,129 posts
Gallery: 15 photos
Likes: 279
Joined Nov 2013
Location: Sweden
     
Aug 15, 2014 03:43 |  #4

Time to upgrade? :)


Fujifilm X100F

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

597 views & 0 likes for this thread
20D suddenly stopped metering correctly
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is amdcasin
1824 guests, 276 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.