Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Community Talk, Chatter & Official Stuff AMASS Forum Software Talk 
Thread started 01 Dec 2014 (Monday) 19:41
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

Bugs in AMASS

 
this thread is locked
Pekka
THREAD ­ STARTER
El General Moderator
Avatar
17,828 posts
Gallery: 35 photos
Best ofs: 7
Likes: 1601
Joined Mar 2001
Location: Hellsinki, Finland
     
Dec 28, 2014 16:57 as a reply to  @ post 17354695 |  #346

Never mind, I deleted that draft manually, it should be gone now.


The Forum Boss, El General Moderator
AMASS 2.1 Changelog (installed here now)

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
the ­ flying ­ moose
Goldmember
1,640 posts
Likes: 76
Joined Dec 2006
Post edited over 5 years ago by the flying moose.
     
Dec 28, 2014 16:57 |  #347

Pekka wrote in post #17354695 (external link)
What name?

togish1. It's always the same name since the first time it happened.

Also, I started getting this warning when I hit the "quote" button. It happens immediately. It doesn't wait like it is trying to do something. It just does it instantly.

It happened once before but I thought it was no big deal but its happened the last three times I tried to quote you. Once I close Safari and re-open it, it goes away.

edit: forgot to say it only occurs when I quote someone. Hasn't happened when I reply or when I click post to thread.


HOSTED PHOTO
please log in to view hosted photos in full size.




  
  LOG IN TO REPLY
Pekka
THREAD ­ STARTER
El General Moderator
Avatar
17,828 posts
Gallery: 35 photos
Best ofs: 7
Likes: 1601
Joined Mar 2001
Location: Hellsinki, Finland
     
Dec 28, 2014 16:59 |  #348

the flying moose wrote in post #17354704 (external link)
togish1. It's always the same name since the first time it happened.

Also, I started getting this warning when I hit the "quote" button. It happens immediately. It doesn't wait like it is trying to do something. It just does it instantly.

It happened once before but I thought it was no big deal but its happened the last three times I tried to quote you. Once I close Safari and re-open it, it goes away.

Try Chrome or Firefox. Safari is not a stable browser.


The Forum Boss, El General Moderator
AMASS 2.1 Changelog (installed here now)

  
  LOG IN TO REPLY
the ­ flying ­ moose
Goldmember
1,640 posts
Likes: 76
Joined Dec 2006
     
Dec 28, 2014 17:03 |  #349

Pekka wrote in post #17354707 (external link)
Try Chrome or Firefox. Safari is not a stable browser.

I will try Chrome. Safari is the only one I've used that will not cause me to log out each time I close the page. Firefox does that to me every time.




  
  LOG IN TO REPLY
Pekka
THREAD ­ STARTER
El General Moderator
Avatar
17,828 posts
Gallery: 35 photos
Best ofs: 7
Likes: 1601
Joined Mar 2001
Location: Hellsinki, Finland
     
Dec 28, 2014 17:04 |  #350

the flying moose wrote in post #17354712 (external link)
I will try Chrome. Safari is the only one I've used that will not cause me to log out each time I close the page. Firefox does that to me every time.

There is a browser setting "delete cookies on exit". Disable that and you'll stay logged.


The Forum Boss, El General Moderator
AMASS 2.1 Changelog (installed here now)

  
  LOG IN TO REPLY
the ­ flying ­ moose
Goldmember
1,640 posts
Likes: 76
Joined Dec 2006
     
Dec 28, 2014 17:13 |  #351

Pekka wrote in post #17354718 (external link)
There is a browser setting "delete cookies on exit". Disable that and you'll stay logged.

Already done and it still does it for me. In fact it just did it.

Ok. Here is what I have got going on now.

Safari - works ok. Will not automatically log me out which is why I use it for POTN.

Firefox - will log me out each time I close the page.

Chrome - just installed it and tried to log in. Stalls on this for about 10 seconds, that login message disappears, the page refreshes and I am back at the login screen. Did it 3 times in a row.


HOSTED PHOTO
please log in to view hosted photos in full size.




  
  LOG IN TO REPLY
Pekka
THREAD ­ STARTER
El General Moderator
Avatar
17,828 posts
Gallery: 35 photos
Best ofs: 7
Likes: 1601
Joined Mar 2001
Location: Hellsinki, Finland
     
Dec 28, 2014 17:20 as a reply to  @ the flying moose's post |  #352

Sorry, can't help you as I have no idea what is going on with you computer. I can not help if your system/router/security​suite deletes cookies or prevents them, or you browser crashes or network breaks intermittently. I would love to help but I can not see how and fixing computers is not my area, sorry.


The Forum Boss, El General Moderator
AMASS 2.1 Changelog (installed here now)

  
  LOG IN TO REPLY
the ­ flying ­ moose
Goldmember
1,640 posts
Likes: 76
Joined Dec 2006
     
Dec 28, 2014 19:05 |  #353

Pekka wrote in post #17354752 (external link)
Sorry, can't help you as I have no idea what is going on with you computer. I can not help if your system/router/security​suite deletes cookies or prevents them, or you browser crashes or network breaks intermittently. I would love to help but I can not see how and fixing computers is not my area, sorry.

Ok but this is not just happening on my one computer.

It has been replicated on 5 different machines/devices with different OS. None of which run Avast. It has been tested on 3 different networks with 2 different ISPs and 2 different cellular data networks.

Using Chrome I was able to sign into other sites I use that would use cookies. The only one that would not accept cookies was POTN.

I am at a loss as to what would cause my machines/devices to have a problem which only occurs when I am trying to use POTN.

Thanks for your help trying to fix this.




  
  LOG IN TO REPLY
Nogo
POTN record for # of posts during "Permanent Ban"
8,001 posts
Gallery: 16 photos
Likes: 585
Joined Dec 2013
Location: All Along the Natchez Trace (Clinton, MS)
     
Dec 28, 2014 19:35 |  #354

Pekka, as a temporary measure, could you allow him to have two user names until this problem is figured out. Maybe let him have a second name as "The Grounded Moose." :mrgreen: Then if he could use that account only to receive and send PMs or for anything else that is not working now.

The real reason I am suggesting this is in case there actually is something wrong with his account instead of something computer related, a new account may not have the problem. Just suggesting it as a way to troubleshoot this problem. If a new account works from his computer, that might narrow down what the problem is.


Philip

  
  LOG IN TO REPLY
OhLook
you get what you get
Avatar
19,323 posts
Gallery: 74 photos
Best ofs: 2
Likes: 7171
Joined Dec 2012
Location: California: SF Bay Area
     
Dec 28, 2014 20:08 |  #355

the flying moose wrote in post #17354638 (external link)
I do not know how bots work

I don't know, either, but if someone or something is messing with your account, I wonder whether changing your password would keep him/her/it/them out.


PRONOUN ADVISORY: OhLook is a she. | A FEW CORRECT SPELLINGS: lens, aperture, amateur, hobbyist, per se, raccoon, whoa, more so (2 wds.), shoo-in | Comments welcome

  
  LOG IN TO REPLY
Bill ­ Boehme
Enjoy being spanked
Avatar
7,359 posts
Gallery: 38 photos
Best ofs: 1
Likes: 88
Joined Jan 2007
Location: DFW Metro-mess, Texas
Post edited over 5 years ago by Bill Boehme.
     
Dec 28, 2014 20:20 |  #356

the flying moose wrote in post #17354638 (external link)
I have everything logged out except this session.

I have no idea if this is relevant, but if I correctly understood what Pekka was requesting, logging out of everything also included logging out on your desktop computer. The above makes me think that maybe you stayed logged in on your desktop machine. Just grasping at straws.

the flying moose wrote in post #17354638 (external link)
... There is nothing in my inbox, nothing in my outbox and nothing in drafts. If someone or something was adding a name wouldn't the "unfinished" PM be saved as a draft?

the flying moose wrote in post #17354638 (external link)
... EDIT: I was looking around the new features and when I went to FYEO I saw I had an unfinished reply draft to a post. I know I did not try to reply to that post. I clicked cancel, verified the cancel and then closed the page. I go back into the FYEO and sure enough, there is the unfinished draft again. It also has that same green "content restored" arrow beside it.

As I mentioned previously, I also always see the green arrow even when everything is blank and I have no unfinished drafts. I just ignore it.


Atmospheric haze in images? Click for Tutorial to Reduce Atmospheric Haze with Photoshop.
Gear List .... Gallery: Woodturner Bill (external link)
Donate to Support POTN Operating Costs

  
  LOG IN TO REPLY
the ­ flying ­ moose
Goldmember
1,640 posts
Likes: 76
Joined Dec 2006
     
Dec 28, 2014 21:55 |  #357

Bill Boehme wrote in post #17355004 (external link)
I have no idea if this is relevant, but if I correctly understood what Pekka was requesting, logging out of everything also included logging out on your desktop computer. The above makes me think that maybe you stayed logged in on your desktop machine. Just grasping at straws.

As I mentioned previously, I also always see the green arrow even when everything is blank and I have no unfinished drafts. I just ignore it.

Yes, I did log out of everything including my desktop. I then only logged back in to my desktop, nothing else.




  
  LOG IN TO REPLY
Pekka
THREAD ­ STARTER
El General Moderator
Avatar
17,828 posts
Gallery: 35 photos
Best ofs: 7
Likes: 1601
Joined Mar 2001
Location: Hellsinki, Finland
Post edited over 5 years ago by Pekka.
     
Dec 29, 2014 03:50 |  #358

Nogo wrote in post #17354935 (external link)
The real reason I am suggesting this is in case there actually is something wrong with his account instead of something computer related

His account integrity 100%. There is nothing wrong there. I can see all that goes on and it works as with all other members.

the flying moose wrote in post #17354888 (external link)
Ok but this is not just happening on my one computer.

It has been replicated on 5 different machines/devices with different OS. None of which run Avast. It has been tested on 3 different networks with 2 different ISPs and 2 different cellular data networks.

And yet, the error message you presented in another post came from Avast.

What you have described sounds like you are not the only one using the computer(s), and that there is Avast somewhere in the network, and there are javascript errors for files that are not served by POTN at all.

Wrong javascript (wrong jQuery library) WILL mess things up, so that is my guess - perhaps some location based CDN router picks up web page's JQuery requests and returns their own jQuery.

Using Chrome I was able to sign into other sites I use that would use cookies. The only one that would not accept cookies was POTN.

I am at a loss as to what would cause my machines/devices to have a problem which only occurs when I am trying to use POTN.

Thanks for your help trying to fix this.

The cookie mechanism is EXACTLY the same whether you login from Safari, FF, Chrome or any browser. As you can log in from Safari just fine, then this end is ruled out as culprit. If a cookie is saved on Safari and not on FF, it means something in FF prevents it.

the flying moose wrote in post #17355149 (external link)
Yes, I did log out of everything including my desktop. I then only logged back in to my desktop, nothing else.

No, you did not log out from all, there was one machine left which I kicked out manually.

I have to leave this problem now, I need to finish 1.1.

To all: Speculation is worthless unless hard data can be found that points to the source of the problem. I know my code and I know how moose's sessions, member data and account data looks like. Based on that the account is 100% in order, there is no "fuzzy logic" in there. It either is or is not.


The Forum Boss, El General Moderator
AMASS 2.1 Changelog (installed here now)

  
  LOG IN TO REPLY
the ­ flying ­ moose
Goldmember
1,640 posts
Likes: 76
Joined Dec 2006
     
Dec 29, 2014 04:49 |  #359

Pekka wrote in post #17355378 (external link)
His account integrity 100%. There is nothing wrong there. I can see all that goes on and it works as with all other members.

And yet, the error message you presented in another post came from Avast.

What you have described sounds like you are not the only one using the computer(s), and that there is Avast somewhere in the network, and there are javascript errors for files that are not served by POTN at all.

Wrong javascript (wrong jQuery library) WILL mess things up, so that is my guess - perhaps some location based CDN router picks up web page's JQuery requests and returns their own jQuery.

The cookie mechanism is EXACTLY the same whether you login from Safari, FF, Chrome or any browser. As you can log in from Safari just fine, then this end is ruled out as culprit. If a cookie is saved on Safari and not on FF, it means something in FF prevents it.

No, you did not log out from all, there was one machine left which I kicked out manually.

I have to leave this problem now, I need to finish 1.1.

To all: Speculation is worthless unless hard data can be found that points to the source of the problem. I know my code and I know how moose's sessions, member data and account data looks like. Based on that the account is 100% in order, there is no "fuzzy logic" in there. It either is or is not.

Fair enough. This will be my last post on all the issues I am having. I know it might come across sarcastic but I do thank you for your help. I just wish these issues could go away so I could enjoy POTN like I have for the past 8 years.

I know there is no Avast on any of my systems. I don't even think you can put Avast on phones and tablets.

As for the cookies, if there is an issue with FF or Chrome or Safari, I fail to see how all my other sites that I use that require cookies, work with zero issues, but POTN does not? A completely fresh install of Chrome with no add ons or extensions wouldn't work with POTN but had no problems with the other sites I frequent. I just cannot wrap my head around how 2 different browsers on a tablet, 2 different browsers on a phone, 3 different browsers on a desktop (iMac), 2 different browsers on a Windows machine and 2 different browsers on a macbook all have the same issue with only one site. If cookies were a problem on the browser then all sites that require cookies would be affected, would they not?

Then that maybe proof my account is compromised. I use 3 devices at home and I logged off all 3 and then logged back in only using the desktop as you requested. Any other devices logged on after that would not be mine. Unless I am confused, there is nowhere for me to change my password or else I would have done that already.




  
  LOG IN TO REPLY
Pekka
THREAD ­ STARTER
El General Moderator
Avatar
17,828 posts
Gallery: 35 photos
Best ofs: 7
Likes: 1601
Joined Mar 2001
Location: Hellsinki, Finland
Post edited over 5 years ago by Pekka.
     
Dec 29, 2014 05:16 as a reply to  @ the flying moose's post |  #360

When you are told that cookies are not saved, refresh the page (with Chrome press F12 (open Developer Tools https://developer.chro​me.com/devtools/docs/s​hortcuts (external link)) and then hold the mouse down on the refresh icon and pick "Hard Reload" from the menu, to make absolutely sure the page is reloaded).

Maybe you are logged in, but your pages are served by a stale cache.

As your Safari works, that is equally the proof that AMASS works as designed. This site does not make anything differently based on browser you use.

In Chrome it is also easy to check that cookies are saved:

Open developer Tools
Click "resources" tab
Click "Cookies"
Click "photography-on-the.net"

If there is a cookie there with a long garbled name, size about 300 bytes, then that is the login cookie.

(just to make sure: please do NOT post a screenshot of that window)

See also https://support.mozill​a.org/en-US/questions/1034392 (external link)


The Forum Boss, El General Moderator
AMASS 2.1 Changelog (installed here now)

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

50,702 views & 16 likes for this thread
Bugs in AMASS
FORUMS Community Talk, Chatter & Official Stuff AMASS Forum Software Talk 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is saik
1344 guests, 340 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.