Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Sony Cameras, Lenses & Accessories Sony Cameras 
Thread started 11 Oct 2017 (Wednesday) 10:14
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

Power Issue on RX100 III

 
*Jayrou
Goldmember
Avatar
1,121 posts
Gallery: 5 photos
Likes: 8
Joined Sep 2010
Location: Jersey UK
     
Oct 11, 2017 10:14 |  #1

Hi all, been a while since i was here but wondering if anyone has had power issues on the RX100 after not using it for a while?

Camera was unused for about 10 months and now it takes multiple attempts to start either by a combination of keep pressing the power button, removing battery and replacing or opening and closing the EVF.

I recently went to Venice and the 1st day was a nightmare trying to get it powered on, after that and 50 plus photos it powered on instantly all week, back home and a week unused it back to not powering on at the 1st few attempts then suddenly springs to life again... the next day it's back to not powering on. I thought the batteries may be bad but when it fanally powers on the batteries are fully charged and able to power the camera

The firmware is upto date and not sure what else it could be, any ideas?

Thanks

James


James
Flickr  (external link)
Website (external link)

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

806 views & 0 likes for this thread
Power Issue on RX100 III
FORUMS Sony Cameras, Lenses & Accessories Sony Cameras 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is RoydonsPhotography
534 guests, 412 members online
Simultaneous users record so far is 6430, that happened on Dec 03, 2017

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.