Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Small Compact Digitals by Canon 
Thread started 29 Jan 2018 (Monday) 11:04
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

Epson Stylus Pro 4900 Printer

 
photobug7d
Senior Member
385 posts
Gallery: 24 photos
Likes: 107
Joined Jun 2010
     
Jan 29, 2018 11:04 |  #1

I have a Epson Stylus Pro 4900 with one completely plugged nozzle (c/vm). I have tried everything from windex to eject and recharging the nozzles along with several power clean through the service program which is sold on the internet and used by the service technicians.
Wondering if anyone else with this same printer has had the same issue.




  
  LOG IN TO REPLY
teekay
Goldmember
Avatar
2,904 posts
Likes: 515
Joined Apr 2001
Location: British Columbia, Canada
     
Feb 02, 2018 18:05 |  #2

Google is your friend! Check out this site - one of many that might help you:

https://www.youtube.co​m/watch?v=yyVRONzrCV8 (external link)

I had similar situation on a Canon printer and found the answer to almost anything is out there on YouTube these days.




  
  LOG IN TO REPLY
photobug7d
THREAD ­ STARTER
Senior Member
385 posts
Gallery: 24 photos
Likes: 107
Joined Jun 2010
     
Feb 04, 2018 10:08 as a reply to  @ teekay's post |  #3

I have seen that video and watched pretty much every video on YouTube in that regard. The problem is one does not know if it is the damper unit that needs replacing or not.
Not a cheap try unit in Canadian funds runs you near $500.
Take into account all the ink and maintenance cartridges it uses one may be better off to garbage it and buy a new one.
Loved the printer when it was working but am now ticked I spent 2,000 and is now trash.




  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

1,681 views & 0 likes for this thread
Epson Stylus Pro 4900 Printer
FORUMS Canon Cameras, Lenses & Accessories Small Compact Digitals by Canon 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is rflynn
676 guests, 297 members online
Simultaneous users record so far is 6430, that happened on Dec 03, 2017

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.