Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon Accessories 
Thread started 30 Sep 2008 (Tuesday) 15:21
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

Problem with BG-E3 grip, plz help!

 
jbrown7815
Senior Member
Avatar
731 posts
Joined May 2008
Location: DMAFB,Tucson, Az
     
Sep 30, 2008 15:21 |  #1

Ok I bought this grip used. Looks like new. I go to use on my first shoot, and it works great for maybe 100-200 clicks.

All of a sudden it stops working, I figured the batteruies were dead so I put fresh ones in it. Still nothing. I take grip off and cam works fine. But with grip on, no power whatsoever, nothing.

I tried with AA batteries too.

Anyone have any ideas what it could be?

Thanks

Jesse


~Jesse~

  
  LOG IN TO REPLY
emdzey01
Senior Member
349 posts
Likes: 1
Joined Apr 2008
Location: SoCal
     
Sep 30, 2008 15:24 |  #2

check the on/off switch on the grip itself.


my name is mjay.

Click for my transactions as a seller on POTN

  
  LOG IN TO REPLY
jbrown7815
THREAD ­ STARTER
Senior Member
Avatar
731 posts
Joined May 2008
Location: DMAFB,Tucson, Az
     
Sep 30, 2008 15:31 |  #3

emdzey01 wrote in post #6411334 (external link)
check the on/off switch on the grip itself.

I did :)


~Jesse~

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

892 views & 0 likes for this thread
Problem with BG-E3 grip, plz help!
FORUMS Canon Cameras, Lenses & Accessories Canon Accessories 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is kubo456
825 guests, 239 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.