Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras 
Thread started 30 Dec 2008 (Tuesday) 17:21
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

New 50D not working

 
chef21
Member
Avatar
229 posts
Likes: 4
Joined Jan 2008
Location: Halifax, Nova Scotia
     
Dec 30, 2008 17:21 |  #1

I just received my 50D, charged the battery as per the manual and it's not working. The charger says it is fully charged, but once you turn the camera on, and then turn it off it won't come back on again. If you remove the battery and put it back in the camera usually comes back on (not always). I called the company I purchased it from here in Canada (Vistek) and they say it sounds like bad battery contacts, and that I should return it to them to have a look at. So it looks like it is going back, so now I wait again for a 50D. On the plus side I also purchased a 17-40L, and it is tack sharp. A very very nice lens.


---------------
Canon 5DMKII, Canon 70-200f2.8 ISL, Canon 17-40L f4, Canon EF 50mm 1.8, Manfrotto 190XPROB, Joy Stick Head, BGE3 Grip, Speedlite 430EX, 580EX Lowepro compu daypack, Hoya UV and polarized filters.:D

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
watchtherocks
Senior Member
Avatar
579 posts
Joined Mar 2008
Location: Australia
     
Dec 30, 2008 17:24 |  #2

If it constantly turns on the first time you put the battery in, then chances are it's not the battery contacts. Might need a replacement camera.
My congrats on the lens.


Anyone know anything anywhere anymore?

  
  LOG IN TO REPLY
chef21
THREAD ­ STARTER
Member
Avatar
229 posts
Likes: 4
Joined Jan 2008
Location: Halifax, Nova Scotia
     
Dec 30, 2008 17:29 |  #3

It doesn't always turn on during the first try, sometimes I have to remove and re insert it a few times before it will turn on.


---------------
Canon 5DMKII, Canon 70-200f2.8 ISL, Canon 17-40L f4, Canon EF 50mm 1.8, Manfrotto 190XPROB, Joy Stick Head, BGE3 Grip, Speedlite 430EX, 580EX Lowepro compu daypack, Hoya UV and polarized filters.:D

  
  LOG IN TO REPLY
gjl711
According to the lazy TF, My flatulence rates
Avatar
55,106 posts
Likes: 2215
Joined Aug 2006
Location: Deep in the heart of Texas
     
Dec 30, 2008 17:31 |  #4

Don't even mess with it. If it is not perfect out of the box, exchange it right away.


Not sure why, but call me JJ.
I used to hate math but then I realised decimals have a point.
.
::Flickr:: (external link)
::Gear::

  
  LOG IN TO REPLY
chef21
THREAD ­ STARTER
Member
Avatar
229 posts
Likes: 4
Joined Jan 2008
Location: Halifax, Nova Scotia
     
Dec 30, 2008 17:34 |  #5

yea my fear is that they are just going to send me the same one back, but I won't keep it unless it works properly.


---------------
Canon 5DMKII, Canon 70-200f2.8 ISL, Canon 17-40L f4, Canon EF 50mm 1.8, Manfrotto 190XPROB, Joy Stick Head, BGE3 Grip, Speedlite 430EX, 580EX Lowepro compu daypack, Hoya UV and polarized filters.:D

  
  LOG IN TO REPLY
gjl711
According to the lazy TF, My flatulence rates
Avatar
55,106 posts
Likes: 2215
Joined Aug 2006
Location: Deep in the heart of Texas
     
Dec 30, 2008 17:39 |  #6

Write down the serial number, but I doubt that they would do that. It's not worth their hassle. They are just going to send the camera back to Canon anyway.


Not sure why, but call me JJ.
I used to hate math but then I realised decimals have a point.
.
::Flickr:: (external link)
::Gear::

  
  LOG IN TO REPLY
snmichaels
Member
Avatar
78 posts
Joined Jul 2008
Location: London
     
Dec 30, 2008 18:04 |  #7

Ouch, hope it works out.


-Sami
40D + 17-55 f/2.8 IS

  
  LOG IN TO REPLY
jdmpower
Senior Member
Avatar
333 posts
Joined Dec 2007
     
Dec 30, 2008 18:12 |  #8

Yeah that sucks demand a new camera


www.socalshutterbug.co​m (external link)

  
  LOG IN TO REPLY
Bill ­ Roberts
revolting peasant
Avatar
3,079 posts
Joined Apr 2006
Location: UK
     
Dec 30, 2008 18:15 |  #9

Send it back for a replacement. I know it's frustrating as Hell when this kind of thing happens, but honestly just send it back and it'll be sorted in a few days.

A few weeks down the line you'll have forgotten about the hassle, be enjoying the new camera and it'll be fine.

best wishes


BiLL

  
  LOG IN TO REPLY
tmalone893
Goldmember
Avatar
2,018 posts
Gallery: 54 photos
Likes: 714
Joined Jan 2006
Location: Memphis, TN
     
Dec 30, 2008 18:44 as a reply to  @ Bill Roberts's post |  #10

I had a different issue with my new 50 and just sent it back to the retailer for replacement. I know it sucks. Believe me when I say, "I know how you feel":( but my replacement is on it way to me now. Can't wait until it gets here. Good luck.


Name: Theron
MaxPreps Profile (external link)
My Gear

flickr (external link)
https://www.instagram.​com/theronmalone/ (external link)

  
  LOG IN TO REPLY
Allison06
Member
62 posts
Joined Dec 2008
     
Dec 30, 2008 19:08 |  #11

Sorry to hear that about your 50D. I just ordered mine from JR and I hope I don't encounter similar issue.


| Canon 5D Mark III Gripped |Canon 50D Gripped | 35L F1.4 | 24-105L F4.0 IS | 70-200L F2.8 IS | EF 50mm f1.8 II | 580EX II |

  
  LOG IN TO REPLY
X-WoodButch
Senior Member
Avatar
438 posts
Joined Jun 2005
Location: Folsom Ca.
     
Dec 30, 2008 19:20 |  #12

No question! Have them replace it immediatley! It should work perfectly right out of the box! I'm sure they will do whatever it takes to make you happy. Congrats on both camera/lens. Enjoy!;)


Canon 50d+Grip, 40d+grip, 20d+grip, Nikon D300+grip, Canon MR-14EX TTL Ring Lite, Sigma EF-500 DG ST Flash, Canon EF 70-200mm F4.0 L USM, Canon EF-S 60mm f2.8 Macro lens, Canon 50mm f1.8 2 Niffty-Fifty, Sigma "Bigma" 50-500mm, Tammy 28-75mm, Sigma 18-50mm f3.5-5.6 DC lens, Tokina 12-24mm f4, Canon 85mm f1.8, Sigma Zoom Telephoto 70-200mm f/2.8 II EX DG APO HSM Macro, Manfrotto #3047 legs & head, Bogen/Manfrotto 676B Monopod, Canon Monopod 100, Slik Pro 340 DX Tripod and a bunch of NIKON stuff...

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

1,111 views & 0 likes for this thread
New 50D not working
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member was a spammer, and banned as such!
935 guests, 233 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.