Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Post Processing, Marketing & Presenting Photos RAW, Post Processing & Printing 
Thread started 31 Jan 2009 (Saturday) 18:16
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

LR/Mogrify plugin not compatible with vista64?

 
HappySnapper90
Cream of the Crop
5,145 posts
Likes: 3
Joined Aug 2008
Location: Cleveland, Ohio
     
Jan 31, 2009 18:16 |  #1

I'm trying to use the mogrify plugin with LR2.2 and vista64.

I've read instruction on how to install the plugin and configure it. When I try to export with it, it says the program is not compatabile with vista64.

One strange thing, what I believe the mogrify "program" does not get a ".exe" extension when it is unzipped - but no extension at all. So I renamed mogrify to mogrify.exe and it is about 8.5MB. And it is found in the ..extras subdirectory in the unzipped file.

I've read others using it with vista64 just fine. Anyone know why this is happening?




  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
HankScorpio
Goldmember
Avatar
2,700 posts
Likes: 1
Joined Aug 2007
Location: England, baby!
     
Jan 31, 2009 18:43 |  #2

It's more than likely you renaming something. I never renamed anything and it works just fine under Vista 64 bit for me. Are you sure you downloaded the correct windows binary for ImageMagick?

You should use ImageMagick-6.4.8-10-Q16-windows-x64-static.exe from the windows binary section of downloads.


My collection of boxes with holes (external link)
EXIF semper intacta.
Gort! Klaatu barada nikto.

  
  LOG IN TO REPLY
HappySnapper90
THREAD ­ STARTER
Cream of the Crop
5,145 posts
Likes: 3
Joined Aug 2008
Location: Cleveland, Ohio
     
Jan 31, 2009 18:47 |  #3

HankScorpio wrote in post #7228684 (external link)
Are you sure you downloaded the correct windows binary for ImageMagick?

Instructions did not state anything about that. Please elaborate.




  
  LOG IN TO REPLY
HankScorpio
Goldmember
Avatar
2,700 posts
Likes: 1
Joined Aug 2007
Location: England, baby!
     
Jan 31, 2009 18:50 |  #4

It's the 3rd one down in the list here

http://www.smudge-it.co.uk …ary-releases.html#windows (external link)

ImageMagick-6.4.8-10-Q16-windows-x64-static.exe is the correct binary for windows Vista 64 bit.


My collection of boxes with holes (external link)
EXIF semper intacta.
Gort! Klaatu barada nikto.

  
  LOG IN TO REPLY
HappySnapper90
THREAD ­ STARTER
Cream of the Crop
5,145 posts
Likes: 3
Joined Aug 2008
Location: Cleveland, Ohio
     
Jan 31, 2009 20:15 |  #5

I installed it, but still doesn't work. Here's the error message:

'"E:\LR2 plugins\LR2Mogrify.lrp​lugin\LRMogrify.extras​\mogrify"' is not recognized as an internal or external command,
operable program or batch file.


The error occured when trying to run this command:
"E:\LR2 plugins\LR2Mogrify.lrp​lugin\LRMogrify.extras​\mogrify" -virtual-pixel mirror -filter Cubic -resize "825x550!" -quality 51 -strip "C:\Users\Admin\AppDat​a\Local\Temp\LR-2-6.jpg"




  
  LOG IN TO REPLY
HankScorpio
Goldmember
Avatar
2,700 posts
Likes: 1
Joined Aug 2007
Location: England, baby!
     
Feb 01, 2009 07:17 |  #6

Ah, I think what you are trying to do is run the plugin as if it were an application and it's not, it's a plugin that Lightroom runs.

Have you opened lightroom and installed the plugin from the plugins manager?

Have you installed Image Magick from the self installing link I posted?

Have you opened lightroom, opened the export dialog and set LR/Mogrify configuration to point to the mogrify.exe that was inatalled with imagemagick? not point it to the LR/Mogrify plugin?


My collection of boxes with holes (external link)
EXIF semper intacta.
Gort! Klaatu barada nikto.

  
  LOG IN TO REPLY
HappySnapper90
THREAD ­ STARTER
Cream of the Crop
5,145 posts
Likes: 3
Joined Aug 2008
Location: Cleveland, Ohio
     
Feb 01, 2009 08:33 |  #7

HankScorpio wrote in post #7231189 (external link)
Ah, I think what you are trying to do is run the plugin as if it were an application and it's not, it's a plugin that Lightroom runs.

Have you opened lightroom and installed the plugin from the plugins manager?

Have you installed Image Magick from the self installing link I posted?

Have you opened lightroom, opened the export dialog and set LR/Mogrify configuration to point to the mogrify.exe that was inatalled with imagemagick? not point it to the LR/Mogrify plugin?

Ok, it works now. But what horrible instructions the creator of this plugin provides. He doesn't tell you to also install the imagegimmick file, plus he doesn't tell you not to use the mogrify file in the plug-in directory instead of the mogrify file in the imagegimmick directory. He needs a lesson in writing clear instructions.

Thanks for your help though.




  
  LOG IN TO REPLY
René ­ Damkot
Cream of the Crop
Avatar
39,856 posts
Likes: 8
Joined Feb 2005
Location: enschede, netherlands
     
Feb 01, 2009 14:27 |  #8

HappySnapper90 wrote in post #7231502 (external link)
He doesn't tell you to also install the imagegimmick file,

He does: Here (external link)

timothyarmes.com wrote:
Step 1: Installing ImageMagick (Windows users only)

To use this plug-in, Windows users must install ImageMagick. Mac users do not need do this since the plug-in includes its own version.


"I think the idea of art kills creativity" - Douglas Adams
Why Color Management.
Color Problems? Click here.
MySpace (external link)
Get Colormanaged (external link)
Twitter (external link)
PERSONAL MESSAGING REGARDING SELLING OR BUYING ITEMS WITH MEMBERS WHO HAVE NO POSTS IN FORUMS AND/OR WHO YOU DO NOT KNOW FROM FORUMS IS HEREBY DECLARED STRICTLY STUPID AND YOU WILL GET BURNED.

  
  LOG IN TO REPLY
TheHoff
Don't Hassle....
Avatar
8,804 posts
Likes: 14
Joined Jan 2008
Location: Vancouver, BC
     
Feb 01, 2009 14:45 |  #9

HappySnapper90 wrote in post #7231502 (external link)
Ok, it works now. But what horrible instructions the creator of this plugin provides.

You should demand your money back.


••Vancouver Wedding Photographer  (external link)••| [gear list] | Latest blog: 5 steps to stopping image loss (external link)

  
  LOG IN TO REPLY
Victoria ­ Bampton
Goldmember
Avatar
1,367 posts
Likes: 7
Joined May 2007
Location: Southampton, UK
     
Feb 02, 2009 16:19 |  #10

HappySnapper90 wrote in post #7231502 (external link)
But what horrible instructions the creator of this plugin provides.

Drop Tim an email and tell him your experience (nicely!). He's a nice guy, but when you're close to a product, it's sometimes hard to know what you need to explain, and which bits aren't clear.


Victoria :D
Lightroom Queen website (external link)
Free & Comprehensive Lightroom Books (external link)
Free List of Lightroom Keyboard Shortcuts (external link)

  
  LOG IN TO REPLY
Mike
ugly when I'm sober
Avatar
15,397 posts
Gallery: 50 photos
Best ofs: 1
Likes: 381
Joined Nov 2006
Location: Canterbury/Ramsgate, UK
     
Aug 24, 2009 10:53 |  #11

HankScorpio wrote in post #7228684 (external link)
Are you sure you downloaded the correct windows binary for ImageMagick?

You should use ImageMagick-6.4.8-10-Q16-windows-x64-static.exe from the windows binary section of downloads.

HankScorpio wrote in post #7228714 (external link)
It's the 3rd one down in the list here

http://www.smudge-it.co.uk …ary-releases.html#windows (external link)

ImageMagick-6.4.8-10-Q16-windows-x64-static.exe is the correct binary for windows Vista 64 bit.

Ah...I'm glad you have answered that - I upgraded to a Vista 64 setup and couldn't get mogrify to work either...I'll give this a go later on. I think I installed the wrong version too!! :oops:


www.mikegreenphotograp​hy.co.uk (external link)
Gear
UK South Easterners
flickr (external link) Insta1 (external link) Insta2 (external link)

A closed mouth gathers no foot.

  
  LOG IN TO REPLY
HankScorpio
Goldmember
Avatar
2,700 posts
Likes: 1
Joined Aug 2007
Location: England, baby!
     
Aug 24, 2009 11:37 |  #12

The version linked may have been updated since I posted that.


My collection of boxes with holes (external link)
EXIF semper intacta.
Gort! Klaatu barada nikto.

  
  LOG IN TO REPLY
Mike
ugly when I'm sober
Avatar
15,397 posts
Gallery: 50 photos
Best ofs: 1
Likes: 381
Joined Nov 2006
Location: Canterbury/Ramsgate, UK
     
Aug 24, 2009 11:42 |  #13

Ah right, thanks for the heads up. :D


www.mikegreenphotograp​hy.co.uk (external link)
Gear
UK South Easterners
flickr (external link) Insta1 (external link) Insta2 (external link)

A closed mouth gathers no foot.

  
  LOG IN TO REPLY
PixelMagic
Cream of the Crop
5,546 posts
Likes: 4
Joined Nov 2007
Location: Racine, WI
     
Aug 24, 2009 12:14 |  #14

ImageMagick is updated regularly but it doesn't matter whether you use the X86 or X64 version. You need to point the LR2/Mogrify plug-in to the location of ImageMagick through the configuration tab. Without this step Mogrify will not work.


Gear List

  
  LOG IN TO REPLY
HappySnapper90
THREAD ­ STARTER
Cream of the Crop
5,145 posts
Likes: 3
Joined Aug 2008
Location: Cleveland, Ohio
     
Aug 24, 2009 14:06 |  #15

Thanks for bringing this up again. I was using a version that had updating broken.




  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

6,992 views & 0 likes for this thread
LR/Mogrify plugin not compatible with vista64?
FORUMS Post Processing, Marketing & Presenting Photos RAW, Post Processing & Printing 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is mcsdet
1543 guests, 277 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.