Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS General Gear Talk Flash and Studio Lighting 
Thread started 23 Feb 2009 (Monday) 19:22
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

430ex not firing any thoughts?

 
jcp2000
Senior Member
Avatar
988 posts
Joined May 2008
Location: California
     
Feb 23, 2009 19:22 |  #1

soo a friend of mine has a 430ex 1 and it just stopped firing. the batteries are fully charged ect. but it just wont fire, it charges up and the red ready (fire) light comes on but it will not fire. even with the test button it will not fire. were stumped any ideas?


Canon 7D, Sigma 24-70 f2.8 EX DG, Vivitar 285HV, AlienBees B800, Vagabond II, Cactus V2s, SLIK Able 300 DX

flickr (external link)



  
  LOG IN TO REPLY
Stirfried
Member
122 posts
Joined Feb 2009
Location: Suzhou, China
     
Feb 23, 2009 22:11 |  #2

Broken? ^^ If it suddenly stopped working, without being dropped or anything, then its most likely the bulb. You can order a replacement bulb from Canon and replace it yourself - I *think* a soldering iron might be needed, but its apparently not hard.


5DmkII, 400D, 24-105mm f/4L IS, 70-200mm f/2.8L IS, 135mm f/2L, 35mm f/1.4L, Sigma 150mm f/2.8 macro, 85mm f/1.8, 50mm f/1.4, Sigma 10-20mm f/4.0, Tamron 18-250mm f/3.5.... Flickr (external link)

  
  LOG IN TO REPLY
Bob_A
Cream of the Crop
Avatar
8,438 posts
Gallery: 48 photos
Likes: 44
Joined Jan 2005
Location: Alberta, Canada
     
Feb 23, 2009 22:18 |  #3

Try another set of brand new alkalines. If that doesn't work it looks like its broken, so hopefully it's still under warranty.


Bob
SmugMug (external link) | My Gear Ratings | My POTN Gallery

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

824 views & 0 likes for this thread
430ex not firing any thoughts?
FORUMS General Gear Talk Flash and Studio Lighting 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is S7TSLLC
680 guests, 244 members online
Simultaneous users record so far is 6430, that happened on Dec 03, 2017

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.