Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras 
Thread started 03 Jun 2009 (Wednesday) 17:49
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

1Ds Mark III dead, need some thoughts

 
P51Mstg
Goldmember
Avatar
1,336 posts
Likes: 2
Joined Feb 2007
Location: Mt. Carmel, TN
     
Jun 03, 2009 17:49 |  #1

I figure if anyone would have a clue it would be you. Can't seem to find anything on the forums.

I have a 1Ds Mark III, about 14 months old. Worked fine until..........

I tried a Vivitar 285 flash on it (I couldn't find the 580EXII)...... Flash didn't shoot, I put it on PROGRAM, flash went off, I shot again, flash went off again........ CAMERA IS DEAD........

I pulled the CR2025 battery out, and "rebooted it". Came up and worked. I was happy.

I shot a few test pics and let it set for a few hours. Camer is DEAD AGAIN.

I pulled the CR2025 again, when I put the LP4 battery back in, the drive light lit, camera came up and worked.

It sat a few more minutes and its dead again.

I figured bad install on the CR2025 or a dead CR2025, so I went to KMART and bought another, put it back in and its STILL DEAD.......

I figure that after the flash since it worked, camera must not be damaged. Must be bad installation of the CR2025 or a dead NEW CR2025 (bought a bad battery)..... I'm out to get a new battery now.

LP4 recharagable battery is good and works in the other 1D Mark IIIs I have (got 2 others)........

Got any ideas?

I don't know if they camera will not work without the CR2025 battery....... I'm guessing it will not. Any help will be appreciated before it gets sent back to Canon (at great expense and I actually need it this week too).........

THANKS

Mark H


Too Much Camera Stuff......

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
Karl ­ Johnston
Cream of the Crop
9,334 posts
Likes: 3
Joined Jul 2008
     
Jun 03, 2009 19:21 |  #2
bannedPermanent ban

Man that sucks.


Adventurous Photographer, Writer (external link) & Wedding Photographer (external link)

  
  LOG IN TO REPLY
edgardavids
Junior Member
23 posts
Joined Jan 2009
     
Jun 03, 2009 19:27 |  #3

Was the vivitar 285 the HV version? If not, the high voltage sync of the vivitar 285 (non-HV) or 283 would've fried your camera.




  
  LOG IN TO REPLY
Duncan ­ Frenz
Purposely evaded the TF
Avatar
1,553 posts
Joined Jan 2009
Location: NE Ohio, USA
     
Jun 03, 2009 19:32 as a reply to  @ Karl Johnston's post |  #4

The CR2025 battery is only responsible for maintaining memory functions such as clock, Cf.N settings, etc. The camera will work with the main battery regardless of the state of your CR2025, though you will have to reset your preferences each time.

It sounds like your Vivitar flash damaged your camera through the hotshoe. I wouldn't use it with your other cameras until it and your camera are tested and repaired.


- Duncan
Gear_Mor
e than I need, Less than I want
Nonconformists are all alike.
I am not an expert, but I play one on the internet.:D

  
  LOG IN TO REPLY
timnosenzo
Cream of the Crop
8,831 posts
Likes: 10
Joined Sep 2005
Location: CT
     
Jun 03, 2009 19:37 |  #5

edgardavids wrote in post #8044861 (external link)
Was the vivitar 285 the HV version? If not, the high voltage sync of the vivitar 285 (non-HV) or 283 would've fried your camera.

ouch! :(


connecticut wedding photographer (external link)

  
  LOG IN TO REPLY
Blue ­ Deuce
"I don't say anything witty"
Avatar
3,751 posts
Likes: 34
Joined Feb 2005
Location: Cent. Fl.
     
Jun 03, 2009 19:48 |  #6

edgardavids wrote in post #8044861 (external link)
Was the vivitar 285 the HV version? If not, the high voltage sync of the vivitar 285 (non-HV) or 283 would've fried your camera.

My thoughts as well.




  
  LOG IN TO REPLY
Colorblinded
Goldmember
Avatar
2,639 posts
Gallery: 17 photos
Best ofs: 1
Likes: 393
Joined Jul 2007
     
Jun 03, 2009 19:53 |  #7

Blue Deuce wrote in post #8044963 (external link)
My thoughts as well.

same


http://www.colorblinde​dphoto.com (external link)
http://www.thecolorbli​ndphotographer.com (external link)

  
  LOG IN TO REPLY
cosworth
I'm comfortable with my masculinity
Avatar
10,930 posts
Likes: 10
Joined Jul 2005
Location: Duncan, BC, Canada
     
Jun 03, 2009 20:06 |  #8

The camera has internal fuses for this contingency. Send it to Irvine and sell the Vivitar


people will always try to stop you doing the right thing if it is unconventional
Full frame and some primes.

  
  LOG IN TO REPLY
Jon_Doh
Senior Member
Avatar
868 posts
Gallery: 1 photo
Likes: 63
Joined Apr 2007
Location: Pyongyang, North Korea
     
Jun 03, 2009 20:24 |  #9

What Edgar said. And if that's the case, we all feel your pain.


I use a Kodak Brownie

  
  LOG IN TO REPLY
dan ­ j
Goldmember
Avatar
1,575 posts
Joined Nov 2008
Location: Florida
     
Jun 03, 2009 20:40 |  #10

Wow, that's terrible. I have heard of the fuses Jason's mentioning, I hope they're real and protected the camera.

This is why I'm surprised the hot shoe design hasn't been changed. Hmmm, maybe Sony does know something ;)

dan


5D Mark 2/24-70L/100-400L

  
  LOG IN TO REPLY
P51Mstg
THREAD ­ STARTER
Goldmember
Avatar
1,336 posts
Likes: 2
Joined Feb 2007
Location: Mt. Carmel, TN
     
Jun 03, 2009 21:05 as a reply to  @ dan j's post |  #11

I've heard enough. Unfortunately, I'm not at home, I'm almost thinking its the HV version on the flash that I have, but not sure.

I do know its not the CR2025 battery, 2 of those and both can't be bad.

I thought it was the flash at first, but it worked after the flash (not right, but worked. I'm sure Canon and my American Express Card can sort it out.

I will say this, when I get the final word on it and the final bill, I'll let you all know.

As always, I appreciate your advice and suggestions. I really appreciate the sympathy...... I need that now, I feel sick. Jack Daniels here I come (just kidding).

Thanks

Mark H


Too Much Camera Stuff......

  
  LOG IN TO REPLY
SuzyView
Cream of the Crop
Avatar
32,073 posts
Gallery: 5 photos
Likes: 117
Joined Oct 2005
Location: Northern VA
     
Jun 03, 2009 21:06 |  #12

Send it in. Worst case, you pay the $200 to get it working again.


Suzie - Still Speaking Canonese!
5DIV, 7D2, SL1, G12, iPad Pro, iPhone 6P, 5 L's & 2 Primes, 25 bags.
My children are the reason, but it's the passion that drives me to get the perfect image of everything.

  
  LOG IN TO REPLY
dan ­ j
Goldmember
Avatar
1,575 posts
Joined Nov 2008
Location: Florida
     
Jun 03, 2009 21:17 |  #13

SuzyView wrote in post #8045365 (external link)
Send it in. Worst case, you pay the $200 to get it working again.

$200. Will there be a POTN Pool on the bill? :)
Of course I mean a legal, no-money Pool.

dan


5D Mark 2/24-70L/100-400L

  
  LOG IN TO REPLY
Duncan ­ Frenz
Purposely evaded the TF
Avatar
1,553 posts
Joined Jan 2009
Location: NE Ohio, USA
     
Jun 03, 2009 21:28 |  #14

dan j wrote in post #8045438 (external link)
$200. Will there be a POTN Pool on the bill? :)
Of course I mean a legal, no-money Pool.

dan

Hmmmm... with all that equipment he should be a member of CPS (ELITE!). If I were Canon, I'd cut him some slack... until I found out he put a Vivitar flash on it instead of a Canon, in which case I'd charge him double and send him a refurb 10D.:p


- Duncan
Gear_Mor
e than I need, Less than I want
Nonconformists are all alike.
I am not an expert, but I play one on the internet.:D

  
  LOG IN TO REPLY
dan ­ j
Goldmember
Avatar
1,575 posts
Joined Nov 2008
Location: Florida
     
Jun 03, 2009 21:35 |  #15

Yeah, $12k, in bodies alone, should buy you some minor repairs - even if they're user caused.

Replacing a 1DsIII with a 10D might be too cruel ;)

dan


5D Mark 2/24-70L/100-400L

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

3,709 views & 0 likes for this thread
1Ds Mark III dead, need some thoughts
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is siennalain
1062 guests, 274 members online
Simultaneous users record so far is 6430, that happened on Dec 03, 2017

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.