Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses 
Thread started 04 Dec 2009 (Friday) 10:52
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

Stored Sigma 105 EX Macro Stopped Autofocusing

 
ions
Goldmember
Avatar
1,825 posts
Likes: 10
Joined Nov 2009
Location: Burlington, ON, Canada
     
Dec 04, 2009 10:52 |  #1

This lens was bought new in 2000 and used occasionally for a couple years, then sadly it sat in a camera bag with its caps on for a few years untouched. Last time I used it it worked fine but when I tried using it again on my new 7D it doesn't autofocus. It's doing the same thing on my old SLR as well. It just whirs and whirs if it's way out of focus but if I move so that it's closer to focus it chirps and chirps like a whispering chipmunk. Manual focus, of course, still works. Could it be something simple like cleaning the connections? Simple for someone who knows how to do that I guess, I never have so I don't know. I'm short on cash for a bit so I'd rather try the simple things I can, maybe, do before taking it to a shop where I could get charged a pile for a simple cleaning.

Any thoughts? Any other info I can provide that would help you help me?


Gear: Canon EOS 5D3 | Canon EOS 7D | Canon 24-70L ƒ2.8 | Canon 100L ƒ2.8 | Canon 70-200 ƒ2.8L IS II | Canon 420 EX | Tamrac Evolution 9 | Crumpler 8 MDH | Manfrotto 190QC with 804RC2 head.
flickr (external link)

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
gasrocks
Cream of the Crop
Avatar
13,431 posts
Likes: 1
Joined Mar 2005
Location: Portage, Wisconsin USA
     
Dec 04, 2009 11:12 |  #2

Quick, sell it on eBay. Send it to Sigma for an estimate. Have you considered using it MF only? Most macro work is done that way.


GEAR LIST
_______________

  
  LOG IN TO REPLY
ions
THREAD ­ STARTER
Goldmember
Avatar
1,825 posts
Likes: 10
Joined Nov 2009
Location: Burlington, ON, Canada
     
Dec 04, 2009 11:17 |  #3

Yeah, I do of course use the macro part of it mostly in manual but I also liked using it as a close up but not quite macro lens where the AF was handy. Unfortunately Sigma, as far as I know, does not have a Canadian service office, they go through a place called Gentec... sounds shady to me.


Gear: Canon EOS 5D3 | Canon EOS 7D | Canon 24-70L ƒ2.8 | Canon 100L ƒ2.8 | Canon 70-200 ƒ2.8L IS II | Canon 420 EX | Tamrac Evolution 9 | Crumpler 8 MDH | Manfrotto 190QC with 804RC2 head.
flickr (external link)

  
  LOG IN TO REPLY
Tony-S
Cream of the Crop
Avatar
9,903 posts
Likes: 201
Joined Jan 2006
Location: Fort Collins, Colorado, USA
     
Dec 04, 2009 12:36 |  #4

Are you sure the clutch isn't disengaged?


"Raw" is not an acronym, abbreviation, nor a proper noun; thus, it should not be in capital letters.

  
  LOG IN TO REPLY
ions
THREAD ­ STARTER
Goldmember
Avatar
1,825 posts
Likes: 10
Joined Nov 2009
Location: Burlington, ON, Canada
     
Dec 04, 2009 12:45 |  #5

Do you mean the slider ring from AF to M? If so, yup.


Gear: Canon EOS 5D3 | Canon EOS 7D | Canon 24-70L ƒ2.8 | Canon 100L ƒ2.8 | Canon 70-200 ƒ2.8L IS II | Canon 420 EX | Tamrac Evolution 9 | Crumpler 8 MDH | Manfrotto 190QC with 804RC2 head.
flickr (external link)

  
  LOG IN TO REPLY
ions
THREAD ­ STARTER
Goldmember
Avatar
1,825 posts
Likes: 10
Joined Nov 2009
Location: Burlington, ON, Canada
     
Dec 11, 2009 22:49 |  #6

I was using this lens for some manual focus manual work and the following error showed up on the screen: "Communication between the lens and camera is faulty. Clean the lens contacts."

Okay. How?


Gear: Canon EOS 5D3 | Canon EOS 7D | Canon 24-70L ƒ2.8 | Canon 100L ƒ2.8 | Canon 70-200 ƒ2.8L IS II | Canon 420 EX | Tamrac Evolution 9 | Crumpler 8 MDH | Manfrotto 190QC with 804RC2 head.
flickr (external link)

  
  LOG IN TO REPLY
ions
THREAD ­ STARTER
Goldmember
Avatar
1,825 posts
Likes: 10
Joined Nov 2009
Location: Burlington, ON, Canada
     
Dec 12, 2009 08:32 as a reply to  @ ions's post |  #7

I just googled that phrase and the only search result was this thread.


Gear: Canon EOS 5D3 | Canon EOS 7D | Canon 24-70L ƒ2.8 | Canon 100L ƒ2.8 | Canon 70-200 ƒ2.8L IS II | Canon 420 EX | Tamrac Evolution 9 | Crumpler 8 MDH | Manfrotto 190QC with 804RC2 head.
flickr (external link)

  
  LOG IN TO REPLY
yogestee
"my posts can be a little colourful"
Avatar
13,845 posts
Gallery: 5 photos
Likes: 36
Joined Dec 2007
Location: Australia
     
Dec 12, 2009 08:40 as a reply to  @ ions's post |  #8

Have you tried it on another camera??


Jurgen
50D~700D~EOS M~G11~S95~GoPro Hero4 Silver
http://www.pbase.com/j​urgentreue (external link)
The Title Fairy,, off with her head!!

  
  LOG IN TO REPLY
Snydremark
my very own Lightrules moment
18,491 posts
Gallery: 47 photos
Likes: 1526
Joined Mar 2009
Location: Issaquah, WA USA
     
Dec 12, 2009 08:45 as a reply to  @ yogestee's post |  #9

Try cleaning off the contacts between the lens and the camera body with a pencil eraser and see if that clears it up.


- Eric S.: My Birds/Wildlife (external link) (7D MkII/5D IV, Canon 10-22 f/3.5-4.5, Canon 24-105L f/4 IS, Canon 70-200L f/2.8 IS MkII, Canon 100-400L f/4.5-5.6 IS I/II)
"The easiest way to improve your photos is to adjust the loose nut between the shutter release and the ground."

  
  LOG IN TO REPLY
ions
THREAD ­ STARTER
Goldmember
Avatar
1,825 posts
Likes: 10
Joined Nov 2009
Location: Burlington, ON, Canada
     
Dec 12, 2009 10:31 |  #10

yogestee wrote in post #9182669 (external link)
Have you tried it on another camera??

The only other body I have is an old Elan II, what I upgraded from to my 7D :lol: So, I don't get any errors with it but the lens behaves the same way that I detailed in the first post.

I tried the eraser thing, nothing changed.


Gear: Canon EOS 5D3 | Canon EOS 7D | Canon 24-70L ƒ2.8 | Canon 100L ƒ2.8 | Canon 70-200 ƒ2.8L IS II | Canon 420 EX | Tamrac Evolution 9 | Crumpler 8 MDH | Manfrotto 190QC with 804RC2 head.
flickr (external link)

  
  LOG IN TO REPLY
ions
THREAD ­ STARTER
Goldmember
Avatar
1,825 posts
Likes: 10
Joined Nov 2009
Location: Burlington, ON, Canada
     
Feb 10, 2010 00:15 |  #11

The lens was taken to Gentec for service, $107 later...

Repaired diaphram base plate
Replaced main PCB
Upgraded firmware
Adjusted and cleaned

So far, not very far admittedly cause I haven't had much of a chance to test it, it's worked very well.

I love the bokeh on this lens, it's nice to have it back.


Gear: Canon EOS 5D3 | Canon EOS 7D | Canon 24-70L ƒ2.8 | Canon 100L ƒ2.8 | Canon 70-200 ƒ2.8L IS II | Canon 420 EX | Tamrac Evolution 9 | Crumpler 8 MDH | Manfrotto 190QC with 804RC2 head.
flickr (external link)

  
  LOG IN TO REPLY
KenjiS
"Holy crap its long!"
Avatar
21,355 posts
Gallery: 542 photos
Likes: 2582
Joined Oct 2008
Location: Buffalo, NY
     
Feb 10, 2010 00:27 as a reply to  @ ions's post |  #12

Do you have a DG or non-DG out of curiousity?

My non-DG sadly didnt like my 7D and had to go back..

Come to think of it..i still havnt gotten my money back from that and they received it well over a week ago..


Gear, New and Old! RAW Club Member
Wanted: 70-200. Time and good health
Deviantart (external link)
Flickr (This is where my good stuff is!) (external link)

  
  LOG IN TO REPLY
ions
THREAD ­ STARTER
Goldmember
Avatar
1,825 posts
Likes: 10
Joined Nov 2009
Location: Burlington, ON, Canada
     
Feb 10, 2010 11:19 |  #13

Non DG, It was bought in 2000, pre-DG days, thus the firmware upgrade/main PCB upgrade.


Gear: Canon EOS 5D3 | Canon EOS 7D | Canon 24-70L ƒ2.8 | Canon 100L ƒ2.8 | Canon 70-200 ƒ2.8L IS II | Canon 420 EX | Tamrac Evolution 9 | Crumpler 8 MDH | Manfrotto 190QC with 804RC2 head.
flickr (external link)

  
  LOG IN TO REPLY
adamo99
Goldmember
1,173 posts
Gallery: 6 photos
Likes: 34
Joined Mar 2007
Location: Mississauga, ON
     
Feb 10, 2010 12:37 |  #14

ions wrote in post #9134451 (external link)
Sigma, as far as I know, does not have a Canadian service office, they go through a place called Gentec... sounds shady to me.

Not shady at all - Gentec are the Canadian distributor for Sigma, and are great to deal with.




  
  LOG IN TO REPLY
ions
THREAD ­ STARTER
Goldmember
Avatar
1,825 posts
Likes: 10
Joined Nov 2009
Location: Burlington, ON, Canada
     
Feb 10, 2010 12:56 |  #15

Uhh yeah, I know now. See 3 posts up.


Gear: Canon EOS 5D3 | Canon EOS 7D | Canon 24-70L ƒ2.8 | Canon 100L ƒ2.8 | Canon 70-200 ƒ2.8L IS II | Canon 420 EX | Tamrac Evolution 9 | Crumpler 8 MDH | Manfrotto 190QC with 804RC2 head.
flickr (external link)

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

1,561 views & 0 likes for this thread
Stored Sigma 105 EX Macro Stopped Autofocusing
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is Birdie760
494 guests, 305 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.