Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras 
Thread started 13 Mar 2010 (Saturday) 10:27
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

5D button problem, please help~!

 
MikeMcL
Goldmember
Avatar
1,411 posts
Likes: 1
Joined Jun 2006
Location: Dayton Ohio
     
Mar 13, 2010 10:27 |  #1

I have an original 5d and my "play" button quit working... You know, the one you press to chimp after taking a shot.

if that wasn't bad enough, i also noticed that the small square type button that you use to move around a photo also boes not work in the "down " direction.

So, my question is - does anyone know of a hard reset or some electrical reset i can do to remedy this? I can take out the battery and the cr2 memory battery or whatever if someone thinks it would help.

If anyone has heard of this, please let me know. I am just not in the mood right now to wait for canon service. I would be reduced to using an XT and i just cannot tolerate that for 3 weeks.

Thanks!


350d, 5d, 28-70L, 70-200L, 430EX,
50 1.8, 85 1.8 - full alienbees studio set.

MikeMcLane.comexternal link

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
a_dee
Member
106 posts
Joined Aug 2006
     
Mar 15, 2010 01:01 |  #2

Sounds like the buttons are worn and will require servicing. I've heard you can try using compressed air to blow out any dirt that may have logged in if that's causing poor contact.


6D . SL1
EF-S 24mm f/2.8 . 40mm f/2.8 . 85mm f/1.8 . 70-200mm f/4L IS
Speedlite 430EX . Kenko 1.4x Pro 300DG . Kenko Extension Tube Set
Gone for Now: 5D3 . Rokinon 14mm f/2.8 . 20mm f/2.8 . 35mm f/1.4L

  
  LOG IN TO REPLY
k.lee
Senior Member
395 posts
Likes: 1
Joined Feb 2009
Location: Vancouver, BC
     
Mar 16, 2010 07:26 |  #3

You can remap the "set" button as a playback button. No idea how you can get around the down button though. Good luck.


Kelvin
Gear list

My
Blog
external link / Flickrexternal link

  
  LOG IN TO REPLY
SQMazda6
Senior Member
457 posts
Joined Sep 2007
Location: Plainfield IL
     
Mar 16, 2010 15:49 |  #4

You could just try and take the rear cover off and put it back on. but that is all on you .. i have done it a few times. however i am never satified with anything


5D|BG-E4N|40D|BG-E2|15mm|28mm|35L|17-40L|50L|85 1.2L II|100mm macro|135L |70-200mm 2.8L| 580EX| Cybersync's| 1 bad bag problem!
1 X-wife

  
  LOG IN TO REPLY
MikeMcL
THREAD ­ STARTER
Goldmember
Avatar
1,411 posts
Likes: 1
Joined Jun 2006
Location: Dayton Ohio
     
Mar 19, 2010 14:59 |  #5

ok thanks for the tips. i will try to remap. After further diagnosis, the "play button works from time to time, but the down never works


350d, 5d, 28-70L, 70-200L, 430EX,
50 1.8, 85 1.8 - full alienbees studio set.

MikeMcLane.comexternal link

  
  LOG IN TO REPLY
pinoyplaya
Senior Member
948 posts
Joined Mar 2010
Location: Minneapolis, MN
     
Mar 19, 2010 15:02 |  #6

If you haven't done so, try what you suggested... taking out the batteries. See if that helps.


flickr (external link)Canon EOS 1D Mark III & WTB Canon 6D
Sigma 50mm f/1.4 ART | Sigma 35mm f/1.4 ART
Canon 70-200mm f/4L | Canon 580 EX II

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

901 views & 0 likes for this thread
5D button problem, please help~!
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is susan s
578 guests, 344 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.