Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses 
Thread started 14 Apr 2010 (Wednesday) 22:36
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

Weird 85mm 1.8 problem

 
mabviper
Member
54 posts
Joined Dec 2009
Location: Toronto, Ontario
     
Apr 14, 2010 22:36 |  #1

I'm wondering if any of you ever experience this problem before.

I bought a Canon 85mm 1.8 used locally. I tested its AF on my 450D and it works flawlessly before I bought it. It's sharp wide open as well so I was happy.

The moment I bring it home, I tested the lens further and I found a really weird problem. When I switch to manual focus, it'll be stuck on manual focus... If I try to switch to AF, it'll continue to say MF and obviously AF won't work. The only way to get AF back was to switch the lens to AF, remove the lens to break electronic contact and put it back on. After that, it works like nothing happened.

I'm quite puzzled by this and even contemplated sending it in. The lens is perfect but this problem is kinda weird, lol. Have any of you ever saw this happened with any of your Canon lenses?

Thanks for the help ^^


7D | 15-85mm IS | 30mm f/1.4 | 50mm f/1.8 | 85mm f/1.8 | 580EX II | 430EX II | YN-560

  
  LOG IN TO REPLY
tkbslc
Cream of the Crop
24,604 posts
Likes: 40
Joined Nov 2008
Location: Utah, USA
     
Apr 14, 2010 23:54 |  #2

I might try cleaning the electrical contacts with a pencil eraser.


Taylor
Galleries: Flickr (external link)
EOS Rp | iPhone 11 Pro Max

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

974 views & 0 likes for this thread
Weird 85mm 1.8 problem
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is IamCrom
299 guests, 148 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.