Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras 
Thread started 17 Sep 2010 (Friday) 14:19
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

40D shutter sounds strange

 
MCB
Senior Member
Avatar
668 posts
Joined Jun 2005
Location: Boston, Mass.
     
Sep 17, 2010 14:19 |  #1

Hi.
I'm not quite sure how to describe this, but suddenly the shutter on my 40D sounds different. It seems like a longer sounds, and is sort of mushy or soft sounding. I don't see any difference in my photos and haven't gotten any error messages (yet). But it has over 40,000 clicks on it so I suppose I might be coming up on a failure.

Has anyone else noticed anything like this? Did it happen before a failure?

This and a few hot pixels (only noticeable in really long shots, like 30 seconds to a minute or more) make me think it's a good time to tell the wife I need a 7D.
Silver lining and all that... :)

Anyway, does this change in shutter sound mean something bad?
thanks.




  
  LOG IN TO REPLY
gjl711
"spouting off stupid things"
Avatar
55,607 posts
Likes: 2484
Joined Aug 2006
Location: Deep in the heart of Texas
     
Sep 17, 2010 14:22 |  #2

It's hard to say without hearing the shutter before and after. If you're not seeing any other telltale shutter failure symptom like err99 or a light streak in your photos, I'd chalk it up to paranoia.


Not sure why, but call me JJ.
I used to hate math but then I realised decimals have a point.
.
::Flickr:: (external link)
::Gear::

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

2,216 views & 0 likes for this thread
40D shutter sounds strange
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is EHDM
923 guests, 221 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.