Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon G-series Digital Cameras 
Thread started 06 Oct 2010 (Wednesday) 21:28
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

430EX won't work on G11. Whats wrong?

 
BobsYourUncle
Goldmember
Avatar
1,529 posts
Joined Jan 2008
Location: Calgary Alberta Canada
     
Oct 06, 2010 21:28 |  #1

So I hooked up my 430EX to my G11 and it won't fire.

I must be doing something wrong here. There are not a whole bunch of settings for this thing.

It worked fine on my G9, just plug it on and go. I have not changed any of the flash settings since the G9 but it simply won't fire.

Any ideas?


Set Goals!! If you aim at nothing, you will hit it every time!
EOS 70D
G1X .... and this other stuff
G11 and
380EX & 430EX
G9 - DEAD (self destructed) I'll fix it one day!

  
  LOG IN TO REPLY
BobsYourUncle
THREAD ­ STARTER
Goldmember
Avatar
1,529 posts
Joined Jan 2008
Location: Calgary Alberta Canada
     
Oct 06, 2010 21:38 |  #2

I guess I should have played with it before posting this thread . . . .

I figured it out. Unlike my G9, the G11 has to have the flash setting to Auto or On for the flash to fire. My G9 didn't care what the flash setting said. If I plugged the 430 onto it, it would work in any flash setting, even off.


Set Goals!! If you aim at nothing, you will hit it every time!
EOS 70D
G1X .... and this other stuff
G11 and
380EX & 430EX
G9 - DEAD (self destructed) I'll fix it one day!

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

1,729 views & 0 likes for this thread
430EX won't work on G11. Whats wrong?
FORUMS Canon Cameras, Lenses & Accessories Canon G-series Digital Cameras 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is Seanpeaaa
1403 guests, 407 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.