Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS General Gear Talk Flash and Studio Lighting 
Thread started 04 Dec 2010 (Saturday) 19:20
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

BXRI 500 Error Message

 
wizard13
Goldmember
Avatar
1,169 posts
Likes: 1
Joined Apr 2006
Location: Western NY
     
Dec 04, 2010 19:20 |  #1

Just got the 500/500 BXRI kit a week ago and have used them just a few times and today kept getting an error on one of the units. Every time I turned it on was able to get one shot off or sometimes no shots before it came up with an 'E' but no number. Where the number should have been the little light just kept circling around the area?? So there was nothing like E1 or E2 like the manual states. Anyone have any ideas??
I tried it again about 2 hours later and it seems to be fine. Just wondering if anyone else ever had a similar problem.
Thanks!


Photography = a constant learning process
Website (external link) || Facebook (external link) || Gear/Feedback

  
  LOG IN TO REPLY
spacetime
Goldmember
Avatar
1,276 posts
Joined Oct 2009
     
Dec 05, 2010 00:18 |  #2

I had a similar problem and it was a bad capacitor or solder joint in the power supply that cost me a bit over $200 to fix. Elinchrom wasn't very specific other than to imply that it was likely do to mishandling of the unit on my part. I'd return it to where ever you bought it and get a replacement.




  
  LOG IN TO REPLY
wizard13
THREAD ­ STARTER
Goldmember
Avatar
1,169 posts
Likes: 1
Joined Apr 2006
Location: Western NY
     
Dec 05, 2010 07:49 |  #3

emitecaps wrote in post #11397390 (external link)
I had a similar problem and it was a bad capacitor or solder joint in the power supply that cost me a bit over $200 to fix. Elinchrom wasn't very specific other than to imply that it was likely do to mishandling of the unit on my part. I'd return it to where ever you bought it and get a replacement.

Thanks for the reply. I was wondering if it was something like a bad capacitor or board.


Photography = a constant learning process
Website (external link) || Facebook (external link) || Gear/Feedback

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

694 views & 0 likes for this thread
BXRI 500 Error Message
FORUMS General Gear Talk Flash and Studio Lighting 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is Jpcullen
976 guests, 248 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.