Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras 
Thread started 11 Feb 2011 (Friday) 15:03
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

My 7D is off to Canon!

 
Invertalon
Cream of the Crop
Avatar
6,495 posts
Likes: 21
Joined Jun 2009
Location: Cleveland, OH
     
Feb 11, 2011 15:03 |  #1

After a full year of use, I think it is time I finally send my camera to Canon for a check on it's AF...

I have noticed that even on a tripod, with a high contrast brightly lit subject... The photo can come out perfectly in focus, front focused or back focused. All without changing anything but the focus ring so the camera can re-lock focus. I don't remember this being like this with my T1i and Xsi I had prior. I know many people had the AF adjusted somehow through Canon and reported good results, so I figure why not.

Overall it does OK, but I have noticed this for while... And if Canon can work their magic and make that AF be a tad more reliable, it is worth it!

I just filled out the information and sending out first thing Monday morning.

Anybody have similar behavior with the 7D in one-shot mode? It just seems it should be a tad more consistent.

But like I said, its very minor and is not make or break most of the time.


-Steve
Facebook (external link)
Flickr (external link)

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
Snydremark
my very own Lightrules moment
18,491 posts
Gallery: 47 photos
Likes: 1526
Joined Mar 2009
Location: Issaquah, WA USA
     
Feb 11, 2011 15:11 |  #2

Sent mine in for inconsistent AF results and haven't had a problem since


- Eric S.: My Birds/Wildlife (external link) (7D MkII/5D IV, Canon 10-22 f/3.5-4.5, Canon 24-105L f/4 IS, Canon 70-200L f/2.8 IS MkII, Canon 100-400L f/4.5-5.6 IS I/II)
"The easiest way to improve your photos is to adjust the loose nut between the shutter release and the ground."

  
  LOG IN TO REPLY
vinnie6756
Goldmember
Avatar
1,075 posts
Joined Oct 2009
Location: 45° 6' 0" N / 87° 37' 50" W a.k.a - Marinette, WI
     
Feb 11, 2011 15:12 |  #3

Snydremark wrote in post #11824129 (external link)
Sent mine in for inconsistent AF results and haven't had a problem since

Same here!!




  
  LOG IN TO REPLY
Invertalon
THREAD ­ STARTER
Cream of the Crop
Avatar
6,495 posts
Likes: 21
Joined Jun 2009
Location: Cleveland, OH
     
Feb 11, 2011 15:14 |  #4

So you had the same problem?

Good to hear, I am excited to have it fixed. Although not a HUGE problem for me, it would be nice to have it spot on each time.


-Steve
Facebook (external link)
Flickr (external link)

  
  LOG IN TO REPLY
Snydremark
my very own Lightrules moment
18,491 posts
Gallery: 47 photos
Likes: 1526
Joined Mar 2009
Location: Issaquah, WA USA
     
Feb 11, 2011 16:05 |  #5

You'll still have to account for human error, of course, but you shouldn't get results in which you can't pretty easily identify what went wrong any more.


- Eric S.: My Birds/Wildlife (external link) (7D MkII/5D IV, Canon 10-22 f/3.5-4.5, Canon 24-105L f/4 IS, Canon 70-200L f/2.8 IS MkII, Canon 100-400L f/4.5-5.6 IS I/II)
"The easiest way to improve your photos is to adjust the loose nut between the shutter release and the ground."

  
  LOG IN TO REPLY
Invertalon
THREAD ­ STARTER
Cream of the Crop
Avatar
6,495 posts
Likes: 21
Joined Jun 2009
Location: Cleveland, OH
     
Feb 24, 2011 12:20 as a reply to  @ Snydremark's post |  #6

Got the camera back today, they did AF and exposure adjustments, along with cleaning. I will post the exact repair when I get back home, but it was lengthy! What do they do with exposure adjustments? Never heard of it on a repair.

Now to see if it is more reliable!


-Steve
Facebook (external link)
Flickr (external link)

  
  LOG IN TO REPLY
05Xrunner
Goldmember, Flipflopper.
Avatar
5,750 posts
Gallery: 52 photos
Likes: 494
Joined Dec 2005
Location: Pittsburgh PA
     
Feb 24, 2011 12:23 |  #7

Invertalon wrote in post #11906026 (external link)
Got the camera back today, they did AF and exposure adjustments, along with cleaning. I will post the exact repair when I get back home, but it was lengthy! What do they do with exposure adjustments? Never heard of it on a repair.

Now to see if it is more reliable!

sure hope it is..I sent them to fix a big blob hotpixel in video mode on my new 7D. I got it back and said checked and cleaned and blah blah repair to working order..yet it was there so basically they did nothing but probably let it sit in the corner for a week and shipped back to me.


My gear
Fuji X-T2, Fuji 18-55 2.8-4 OIS, Fuji 35 f2, Fuji 50 f2, Fuji 90 f2, Fuji 55-200 3.5-4.8 OIS
Sony RX100 II

  
  LOG IN TO REPLY
Invertalon
THREAD ­ STARTER
Cream of the Crop
Avatar
6,495 posts
Likes: 21
Joined Jun 2009
Location: Cleveland, OH
     
Feb 24, 2011 12:52 |  #8

It seemed good with the few sample shots I took, and they did clean the dust out of the viewfinder, so at least they did that! And if I still have issues to send in my lens with it.


-Steve
Facebook (external link)
Flickr (external link)

  
  LOG IN TO REPLY
drigo
Goldmember
1,029 posts
Gallery: 77 photos
Best ofs: 3
Likes: 545
Joined Feb 2009
Location: florida
     
Feb 24, 2011 13:04 as a reply to  @ Invertalon's post |  #9

do you mind if i ask how much this repair costs you or is it covered under warranty? thanks


7D/10-22/70-200L f/2.8/ 50 f/1.8 / Rokinon 8mm fisheye /  / 6D Mark II / 16-35L f/2.8 II

  
  LOG IN TO REPLY
Invertalon
THREAD ­ STARTER
Cream of the Crop
Avatar
6,495 posts
Likes: 21
Joined Jun 2009
Location: Cleveland, OH
     
Feb 24, 2011 16:13 |  #10

It was covered under warranty... Even though I have had the camera for a year + 2 months, they still honored it, which was nice!

Here is what the service details said:

"Electrical adjustments were carried out on the AF assembly and product functions were confirmed. Checked all, adjusted focus & exposure, cleaned to factory specs. Cleaned C-mos & IF YOU HAVE A SAME PROBLEM OCCUR, PLS SEND US WITH LENS.


After shooting with it on a tripod like before, the results are more consistent. Taking the same shot over and over has very little difference. Before I would get slightly weird results doing the same thing.

So I am happy with what they did! Time will tell though, when the weather is a bit nicer and I can really test it out. So gloomy out, sadly :(


-Steve
Facebook (external link)
Flickr (external link)

  
  LOG IN TO REPLY
Cassie
Goldmember
Avatar
1,041 posts
Gallery: 191 photos
Likes: 751
Joined Apr 2005
Location: Here, But I'm Gone
     
Feb 24, 2011 18:53 |  #11

Same here, and this post helps me to confirm that I need to bite the bullet and send mine in too. I have been putting it off for a while now, but I think mine needs to be adjusted too. Just to make sure, a couple weeks back, I took photos with all my lenses (tripod, flash, remote shutter release,etc) and looked at them in zoom browser and didn't like what I saw, so I will be sending mine in next week. At least I still have my trusty 20D if I want to shoot.


http://thompson-photo.smugmug.com/ (external link)
https://instagram.com/​vegaquarium (external link)
5D MK IV
35 F/2 IS*Shorty-Forty*50L*85L II*135L :D
430 EX II

  
  LOG IN TO REPLY
Donte
Member
Avatar
162 posts
Joined Oct 2007
Location: San Diego
     
Feb 24, 2011 20:03 |  #12

Same boat as Cassie. I will be sending mine off Monday.




  
  LOG IN TO REPLY
gabebalazs
Bird Whisperer
Avatar
7,640 posts
Gallery: 52 photos
Likes: 1060
Joined Nov 2008
Location: Toledo, OH
     
Feb 24, 2011 20:13 |  #13

I'm thinking of sending mine in too. I too have this wierd phenomenon every now and then. Unfortunately, mine isn't under warranty any more. However, I'm a CPS Gold member, and maybe my two cleaning/adjustment coupon would take care of it for free. If not, I paid for my 7D with an AMEX card, supposedly that gives me another year of warranty. Either way, I'll have it checked.


SONY A7RIII | SONY A7III | SONY RX10 IV | SONY RX100 | 24-70 2.8 GM | 70-200 2.8 GM | 16-35 F/4 | PZ 18-105 F/4 | FE 85 1.8 | FE 28-70 | SIGMA 35 1.4 ART | SIGMA 150-600 C | ROKINON 14 2.8
Gabe Balazs Photo (external link)
Nature Shots Portfolio (external link)

  
  LOG IN TO REPLY
10megapixel
"I'm a little slow"
Avatar
3,872 posts
Likes: 3
Joined Oct 2008
Location: ……Surrounded by Corn and Rednecks in Indiana
     
Feb 24, 2011 22:12 as a reply to  @ gabebalazs's post |  #14

Only had mine for 6 months and no problems at all with the AF, hope it stays that way ;)



Gear List & Feedback



  
  LOG IN TO REPLY
Cassie
Goldmember
Avatar
1,041 posts
Gallery: 191 photos
Likes: 751
Joined Apr 2005
Location: Here, But I'm Gone
     
Feb 25, 2011 11:36 |  #15

Just got my repair order number, and will be shipping off tomorrow. I haven't even boxed the camera up yet and I'm sad already :(


http://thompson-photo.smugmug.com/ (external link)
https://instagram.com/​vegaquarium (external link)
5D MK IV
35 F/2 IS*Shorty-Forty*50L*85L II*135L :D
430 EX II

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

7,352 views & 0 likes for this thread
My 7D is off to Canon!
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is marcuse2004
958 guests, 251 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.